How do I force Lightburn to burn an image at single pass without going over again?

I am trying to burn an image on a rather big drum shaped item. If I just burn “outline” only, it comes out perfect. If I try to burn “fill”, I see a double images misaligned. If everything was perfectly square and round, I wouldn’t have this issue but that is not the case given the size of the drum. I can see that the second pass created a great image but not aligned with the first one. Please note that I am only using a single pass and all default settings including the pass optimization.
Is there a setting that would force the app to use a single pass? I suspect this is something to do with optimization settings.

Thanks in advance.

You likely have duplication of objects or your two layers have overlapping lines.

Are you able to share the .lbrn file to review.

Are you using a rotary? It sounds like the object may be slipping between passes.

yes i am using the rotary. Most likely it is caused by a slippage and the object being not 100% perfect. That’s why I am trying to figure out away to burn it in a single pass. Why does it make a multiple passes when I set it to only a single pass? Is there a way so that it won’t come back to burn the same image again? In other words, is there a way to instruct the laser to burn from top to bottom gradually in a single pass instead of moving around? Thanks

1200/80. I guess I cannot simply configure it so that it will burn top to bottom in a single pass without going back up later. I know at about 50% progress, the image is very good and I can manually stop… that would be a hacky way to overcome this issue… thanks for your help.

I also found out there is an advance setting to configure 1) fill shape individually 2) configure the line speed to 1000 (it defaults to a much higher speed). In the end , I only used fill and chose fill shape individually. That worked.

It would help us if you could elaborate on what the ‘rather big drum shaped item’ actually is. We are all guessing it’s a cup/mug…

Your .lbrn2 file may give us some hints, if you could post it.

We can’t guess why you can’t do what you are trying to do if we can’t see the artwork and how you have your layers set.

Pictures generally help.

How are you engraving the ‘object’? Which axes have you got doing what…?

Here is mine, scanning left to right most movement is the X axes. The cup has to move only the amount of a single scan line step, your lpi.

With this minimal amount of movement there is less chance of ‘slippage’.

If I scan it up/down the cup is rotated one way then abruptly rotated back the other direction.

All of the movements can be modified by the acceleration settings of the controller. I have all of my Y axes, acceleration, start speeds and max speeds changed for rotary use.


Here you go! It is much bigger than tumblers and mugs that I did in the past. My coworker just adopted a Saint Bernard so I thought I would give her a set of big bowls as a gift. In the end, it worked out (good enough). It is about 8inch wide. On the back of the bow, there are more stuff engraved like personal messages.

They sit on a YRR (rotary roller from Ortur).

1 Like

Is it working?

It looks OK to me…


Yup! already gave them to my friend!

1 Like

So what exactly solved the problem. Someone else might be interested…


A few things.

  1. I put my finger inside the bowl to press it down to create some friction. I am sure I can make some stuff to hold it down with an adjustable tensioner (something like the leg that the blue arrow points to. However, I don’t think I will do something this big that often. I don’t mind using this manual method. This is to prevent any possible skipping.

  2. The following setting was super helpful so that the head doesn’t move back and forth.

  3. I removed the line and chose only fill.

Again, this is only when you work on a large span of a drum. For a regular size mug and tumblers, a small error is acceptable as it won’t be magnified.

:smiling_face_with_three_hearts: cute dog and nice bowl.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.