How do I get a grid on the homescreen?

I am used to seeing a grid on the designing screen. When I pull up my LightBurn, it is a blank work page, without grid lines. How can I fix that?

Take a look at your ‘Settings’ window (click ‘Gears’ icon, near the top center) to see if you have the grid turned ‘Off’ by chance. Could that be the issue you are seeing?

Thank you very much for your quick response. Unfortunately, it is not off. I am noticing that your visual grid spacing is different than mine. I will try that.

Thank you again hope you have a good day .


Can you show a screen shot of your main window? Do you see a page outline, or nothing at all?

Hello OZ
I have just an outline . The program could not identify my laser and I had to manually input the information. Could this be the problem? I am also trying to use inches instead of mm. ???

… I almost feel like I need to delete and start over. When I try to import and send image over without grid I am getting a Y slope error

This is very odd, and the first report of this I am aware of.

I see you are running LightBurn version 9.07, you might want to consider updating to our latest release which is 9.10 and includes a bunch of new features and some fixes to issues we have resolved.

Yes, I would delete this profile and start a new one. I see you have selected the ‘Ruida’ profile for this setup. This is correct for configuring LightBurn to work with your Boss, but clearly, something did not go correctly.

Let’s start with a new attempt to ‘Find my Laser’ after deleting this existing profile. Let us know how you get on and we will go from there.

Your working area looks to be set incorrectly - i.e. the dimension of the outline on the main screen is ~ 15 mm X 13 mm. You can change it in “device settings”.

I deleted LightBurn and reinstalled… It still can not find my laser and does not have a grid pattern.
I am so sorry to make this so difficult.
I do appreciate everyone’s efforts to help

Rick ,

I think I got it !! Thank you so much for your patience and help !

Thank you very much for your help . I have a grid now.
Have a great day

What version of LightBurn? Did you update? What exact version of Windows are you running?

You do not need to apologize, we will get you sorted. I just need to track down why this is happening for you. With thousands of users, we have not seen this before so please bear with us as we work together to determine the cause and offer a solution.

Please show your ‘Settings’ page for review (click the ‘Gears’ icon near the center-top of LightBurn screen).

Oh, well that is good news. What did you do? What steps did you take to resolve this? Please provide as much detail as you can as we can not reproduce and would like others to benefit from what you learned. And we would like to fix any issue that might be causing this behavior. Thanks and glad you are all set.

I did take your advice and deleted the program that I was having problems with . I downloaded it again using the USB . It still could not “find” my laser, but the previous setting were still in the que. I deleted them as well and started over and input my settings again. I believe that part of the my difficulty was that I had entered my information incorrectly. I have updated the software and was able to transfer my project easily…
I hope this is helpful information
Thank you again for you help, cant begin to tell you how much I appreciate it.

Wow, that was not supposed to be this bumpy. I am sorry this process did not go more smoothly for you. You have motivated me to review our flow again to see if I can recommend some tuning to avoid this potential for others. So for that, thank you. :slight_smile:

I am glad you are sorted and please let us know if you have any further observations or questions.

Thank you again for all of your help . Hope you are having a great day.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.