How do I import pdf (PCB) properly in lightburn?

My pdf file exported from eagle looks like this:

But when I import that file in lightburn. It looks likes this.

Also, when zoomed in I see these lines, which I don’t want. I want it to be completely solid.

I have marked the problematic areas. How can I resolve these issues and also since I’m engraving it with laser, How can I invert the pdf ?

I found some resources in this forum recommending to use outline to invert the pdf but I can’t figure out how to do it.

LightBurn does not handle stroke width, and it doesn’t use “paint”, so anything that “paints over” a black shape with white won’t have the desired effect. If Eagle can export as a high resolution image, I’d suggest going that route instead - LightBurn will engrave from a black & white image just as easily as from a PDF.

I found the really easy and fastest way to this. For anybody who comes looking. I’m listing all the proper steps here:

  1. In Eagle, Click “Options > Set > Misc” and change uncheck these options listed below.

  2. In Layer Settings, select the following layers (For Bottom copper select Bottom layer instead of Top).

  3. Click “File > Export > Image”. Select the highest possible resolution (2400 dpi) and click “OK”

  4. Now the generated image is already inverted. No further modifcations are needed. Just import it directly in LightBurn.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.