How do i revert back from 0.9.13

due to the update messing up the order of engraving I need to revert back. how do I do this?

Details on old versions here: How do I find older versions of LightBurn?

However, can you explain the problem you are having? Either it’s something we can help you resolve or you’ve found a bug that we need to fix. I don’t see any other activity in the forum from you talking about such an issue.

Hi Thanks for the reply. i have reinstalled 0.9.11 as this works for me.

I engrave ruler markings and i have always had an issue with the marking not being marked with consistant line mark after each other. ive tried the optimise but that was worse then not clicking the option. without the option ticked worked well but when i upgraded it both options were all over the place which left the markings inaccurate. hope that make sense.

Do you have a photo to show the level of detail on your markings?


excuse the non-focus of my phone

Not really - What optimization settings do you have enabled, and are you importing the ruler designs in as something, or creating them in LightBurn?

no i have designed them in illustrator. optimised settings sends the lines to mark not in a consistant line ie1mm 2mm 5mm 6mm 3mm so quite random but this causes in accuracy when the laser has to fill in the gaps.

Click the ‘Optimization settings’ button and post a screen shot of the window that pops up.

What material are you engraving on ?
Is that anodized aluminum?

Looks very crisp and clean and very nice.



Im not using optimised setting as i found it all over the place and even worse on the new update. im happy to privately send you the file but has to go no where else.

That’s fine - you can email the file to developer at lightburnsoftware dot com. User-submitted files are only ever used for debugging unless we have explicit permission to do otherwise.

1 Like

With optimization off, on mine it’s reporting 27 minutes, vs 17 minutes with the optimizations enabled, so I’m not sure I understand the issue.

I don’t understand what this means. My best guess is that you mean the machine is losing steps and the marks aren’t lining up. If that’s the case, it’s not a LightBurn issue, it’s the acceleration or speed settings on the machine being too aggressive and so your steppers are losing steps when making lots of short moves.

nothing to do with the laser its defiantly a software issue. just because it runs quick on the visual doesn’t mean its running right, how are the ruler lines marking? are they sequential or do they mark one after each other 1mm 2mm 3mm 4mm and so on. as when i run a visual on the software its all over the place back and forth doing an individual line. if yours is working please send me a screenshot of your settings and i will test on my software.

The order in which those lines are cut should not affect whether your machine puts them in the correct location or not. If it does, that is a machine issue, not software.

The ordering of cuts can make the machine move in a way that promotes resonance if your acceleration settings are too high. If manually ordering the job is giving you the results you need, then keep doing that. If you want help configuring your machine so you no longer have to, we’ll be here.

Thank you for your resonse, i have alway found the issue happening of the laser not marking on the exact position when having to return to a location, i have 2 lasers and it does it on both. what is your suggestion to resolve this if its not a saofware issue? ill look forward to having this recified as its always an issue for us. when we run that file with optimise off we get a total time of 16 mins.

Go to Edit > Machine Settings and post a screen capture of the values in the Cutting and Engraving parts of that window. You have a very large machine, so the gantry is likely to be heavy, and I suspect your acceleration is too high.


Scroll down and grab the Engraving Parameters too?