How to change Machine Settings in Smoothieware K40 conversion (no switch or menu ?)

Tell me exactly how you get to the machine settings screen that you show!! I have tried everything in Lightburn to find that screen even reverting to your version of Lightbuirn and it does NOT exist!! The first one NOT Device settings!

With your Cohesion3D board running Smoothieware instead of GRBL, the switch will not be available in LightBurn. The Snapmaker runs Marlin and likely doesn’t have that option either. Rookie mistake on my part.

The setting to reverse the axis should be in the Configuration File on the SD card that shipped with your board. It may be easier to reverse the motor coil pairs on the motor or motor cabling than correct it in software. Each homebuilt set up or board swap offers its own unique challenges.

If you invert that setting you may need to make other modifications to the firmware file as well.

I attached the image for discussion and moved your comment into the correct section and will correct my error in the other thread.

Please tell us more about your engraver and what you’re working toward. Someone here will know how to get you there.

When lightburn performs a home, either on startup or once selected from the move panel only the X axis homes, Y twiches in the wrong direction but never tries to home. Y works correctly with the move buttons in proper directions. Might add 3D Cohesion board with smoothie firmware. bottom left origin.

I will merge it into the new thread I created based on your other post.

The difference between the homing speed and the often slower jog button speed may be the cause of this. Please share a screen capture of the Move Window. I would like to see if the jog speed is displayed there.

I found this video, It mentions reducing the seek-rate to make travel moves more reliable, which editor you’ll want to use, and how to access the config file.

PLease re-read my problem. The Y axis moves correctly with the jog buttons, I do NOT need to reverse it. IT DOES NOTHING WHEN I HOME!!!
And stepby step where do you find this Lightburn screen?? Not there.

Oh, and BTW Smoothie ware is GRBL - just a customized version.

My apologies, I pulled that image from the conversation that your post was attached to and it seems to have added needless confusion.

That switch and that screen are not part of the Smoothieware functionality.
It is only available to the Opensource GRBL (gnea) project and it’s descendants.
GRBL Machine settings:

It is not available to users of Smoothieware or Marlin because the motion control software is written differently - Customized as you said. While Smoothieware, Marlin, and GRBL all use various versions of GCode; Smoothieware and Marlin (and several other variants) are not GRBL.

Smoothieware: (no machine settings)

The high speed traverse speed used for homing may need to be lowered because your laser has more mass (more parts) to move in the Y-direction than in the X-direction.

This condition may not apply to the jog speed as the jog speed may already be lower for both axes.

The technique to adjust Machine Settings is touched on in the Video above near the 8 minute mark. The settings are in a file called config.txt on the SD card that shipped with your device. To slow the Y-homing speed you will need to reduce the G0 ‘Seek’ rate.

I was warned by the owner of C3D not to use Notepad but I used Notepad here to reveal the settings. There is a wiser recommendation in the video.

I hope this clears things up so you can move forward with your K40 Swap.
Please do reach out with any other questions you may have.

I turned off homing, asked the controller to perform two jog operations and asked for an engraving of a rectangle.

The code passed to the controller without error - it’s powered up, USB connected and is sitting in the cardboard box it shipped in.

The speed applied for jogging operations was the speed in the move window.
The speed applied to travel toward the rectangle was also the speed in the move window.

Changing the speed in the Move window to 24000 mm/minute (the seek rate) or more should provide evidence that the seek rate is too high and responsible for the juddering Y-axis homing symptom.

Smoothieware is absolutely not GRBL. It’s a new codebase with a completely different motion planner. It has a “GRBL compatibility” mode and that’s about the extent of the similarities.

Smoothieware stores the configuration in the text file on the SD card, so you can only make changes by editing that file on the SD and re-inserting it into the controller.

If the Y axis twitches when you try to home, you likely have the seek rate too high, or the Y axis current set too low.

2 things. Cohesion 3D for Lightburn says smoothieware for firmware and shows how to connect it.

The Other is I have already reduced travel speeds in the config.txt using the recommended “Sublime” editor and that didn’t help. Did you NOTE that I SAID Y axis would NOT home withe home command - IT DOES NOTHING. You did not still address that issue.

Indeed, I did note that. I also noted the difference between Nothing and Juddering.

If you are so inclined, please perform the following test at your convenience.

Retesting the Jog buttons at seek-speed should make it behave as if it were attempting to home while using the move buttons. I am optimistic that this symptom will show up here too.

IF I were to switch to true GRBL which GRBL firmware (1.1) from where?

Perhaps you didn’t NOTE that the Y axis moves just fine with the JOG buttons and in the correct directions. Cohesion 3D reccomends their firmware for Lightburn also.

I have not seen a GRBL version written for your controller. Your question may be more ‘if’ than ‘where’.

I don’t understand why you would choose to sacrifice precision and better arc rendering for GRBL. I believe you have an excellent controller.

Reflashing a controller and overcoming the challenges with setting it up from scratch is quite a bit more complicated than the discussion and requested tests so far.

Currently, barring a major mishap, I feel that you’re much closer to being up, and running successfully with your C3D Smoothieware setup.

There’s a bunch of new information to push through and starting is the hard part.
We’ve all been there a few times.

1 Like

@JohnJohn: Y doesn’t home problem solved. You might want to add this to your item knowledge for future reference. Firmware and/or config.txt files were apparently corrupt. Downloaded smoothie cluster default, wiped SD card and copied default with no changes to SD card. loaded and re-booted Cohesion then lightburn everything works fine now. Will tweak other settings one at a time until everything is correct for my size machine.

1 Like