How to change the startup commands?

When I start up and connect to my CNC, Lightburn runs a series of GRBL commands (I use a Shapeoko). I would like to add one to it (the $X command, which seems to have been removed from the startup since v.20) - basically, I want to put it back in in the current release.

Where can I find that sequence of commands? Is it editable?


The command sequence on startup is embedded in the code, and isn’t editable. The $X command isn’t necessary if you home the machine on startup, because that also unlocks it.

LightBurn should automatically unlock the controller if it sees one of these messages:

[MSG:'$H'|'$X' to unlock]
['$H'|'$X' to unlock]

Does yours say either of those on startup?

It used to (and does in .20)…but in .21 and beyond, it just says:

  • Starting stream
  • $10=0
  • $32=1
  • G10 L2 P1 X-845 Y-850
  • error:9
  • G-code locked out during alarm or jog state.
  • On or near line 2:
  • Stream completed in 0:00

I don’t usually home with LB - I just use Use Current Position and zero at center and let it rip. I could home, I suppose, but I never used to.

Those commands are your macro setup macro, and if you’re running them while the machine is in a locked state the GCode line (G10) won’t work. If you add a $X to the first line of the macro, that should work.

Oh…sorry…I’ll have to reinstall the latest version and record the start up sequence.

As long as the startup commands don’t have something in them that is needed that isn’t getting accepted, I can put the $X in the UseLaser macro and not think about it.

But I will take a look at what I"m seeing on start up with the most recent version

@LightBurn OK…I loaded .24.
Since the default is always with “Show All” turned off (it doesn’t remember where I left it the last time), I can’t see what commands are being issued on the console during startup, but what I do see is:
Target buffer size found

I added $X to my UseLaser macro and that worked just fine…so I guess I’m done…although I wouldn’t normally run that macro if I don’t go back to CNC mode in between laser usages…

I think it would be nice to be able to edit the startup sequence…that, to me, is the more elegant solution.

Thanks for your help.

  • Gary

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.