How to move laser to selection using user origin?

I am trying to engrave a mug using a rotary axis. I position the laser at the top center of the cup and set the origin there, then what I would like to do is move the laser to the back side engraving so I can center it on the cup brand. But when I use the “move to center of selection” tool, it uses the machine origin instead of my user origin. Because of the size of the rotary axis I cannot position it at the machine origin.

Is there any workaround for this? Being able to position the laser at specific areas of the engraving could be a huge time saver, but it’s kinda useless if it can’t use my user origin.

From our documentation on the subject: Rotary Setup - LightBurn Software Documentation

  • Align your object under the laser head in a position where the X axis will start and rotate the object in the rotary attachment to the point where you want the Y axis to start engraving.

  • When using the rotary, it’s generally a good idea to use “current position” as the “Start From” setting.

  • Click Start to run your job, or if you have a DSP controller, you can use Send to send it to the controller to run it from there.

Thank you for the reply.

I can do that but what I want is to have my main engraving on the side opposite the brand that comes on the mug, and a small company name on the back side centered over the brand. So being able to use the “move laser to selection” feature would be really great! I could move the laser to the small company name I want on the back then position the mug under the laser where I want that feature engraved. I could then start the job and the engraving would be perfectly aligned on the mug.
But when I click “move laser to selection” it moves to an area near the limit switches because it is using the machine home position instead of the User Origin as the x=0 y=0 position.
I’m sorry if I’m not being clear, I don’t always know the right lingo.

Did you try the suggested?

Thanks, I tried using current position but it just rotates the cup for a very long time until I cancel it. Maybe it’s because the rotary axis is set to 10,000? Since there is no limit switch on the rotary I don’t know how I can zero it. I tried re-enabling the homing on the rotary axis but then the x axis moves slightly then stops, failing to home, and I see no sign of the rotary attempting to home at all. I was thinking I could just bump the limit switch when it tries to home but that’s not working.
Thanks for your help, I’ve been struggling with this for weeks and it’s very frustrating.

ok I managed to fake out the homing on the limit switch, but move\ laser to selection still doen’t repect my user origin and moves to the top of the bed, even with lightburn set to start from current position