How to set up lightburn if limit-switch homing is on the right corner


after adding Z-Axis, 3 limit switches and some fight with homing configuration it seems now to work. But the green dot is on the left/down corner, if I move Laser left, then it is then outside of the working sheet and X value go in “-” direction. If I change the orygin configuration to the right-bottom corner, then the X-move direction is wrong.

Any idea how to fix it?

The perfect solution will be, if light burn will do homing on the right-bottom corner and move to the left corner and set the dot to the left-bottom corner of the working sheet. I know the max width to be able to move to the left-bottom corner.

Can you run these checks and report back:

  1. Run in console:
  1. Keep origin at lower left and run these steps.
    2a. Home laser (I assume to lower right) - Run ? in Console
    2b. Move laser head to lower left - Run ? in Console
    2c. Move laser head to upper left - Run ?' in Console 2d. Move laser head to upper right - Run ?` in Console

Return results and will evaluate next steps.

Target buffer size found

2a) ? <Idle|MPos:0.000,0.000,0.000|FS:0,0|WCO:-875.000,0.000,0.000>
2b) ? <Idle|MPos:-1025.000,0.000,0.000|FS:0,0|WCO:-875.000,0.000,0.000>
2c) <Idle|MPos:-1025.000,1035.000,0.000|FS:0,0|WCO:-875.000,0.000,0.000>
2d) <Idle|MPos:0.000,1035.000,0.000|FS:0,0|WCO:-875.000,0.000,0.000>

  1. Change status setting to send working position, not machine position
  1. Correct offset to put bottom-left as origin
G10 L2 P1 X-1025 Y0

Your machine will not automatically go to 0,0 after homing but will treat bottom-left as origin.

Thanks it seems to work :slight_smile:

Zdavo,kako da dodjem do programa lightburn ,kako ga kupiti

Hi, how to get to the lightburn program, how to buy it

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.