How to wrap text to a line

I need to make text follow a circle for a logo I am creating. I have watched multiple videos about the process, but none of them match what I see on my screen.

  • When I select the line and text, I don’t have an “Apply path to text” option when I right-click.
  • When I go into Tools, the “Apply line to text” is always grayed out.
  • If I click on the text, I don’t see the little blue dot that some videos show where I could just bend the text without a line.

We have Lightburn 1.0.06
Any help is much appreciated!!

I’ve never seen that. This is what I see:

Oh! I’m new to this (obviously!) I don’t have a file. I just clicked on the “A” text icon in lightburn itself.

I just typed the word into Lightburn after selecting the “A” tool on the left.


Thanks so much for working through this with me. The file literally has nothing beyond what you see. I just opened it and typed that one word.
Logo.lbrn2 (53.7 KB)


Thank you. I follow what’s being explained, but when I try that in my file, I can’t select “Apply path to text” because it’s gray. How can I activate that option??

I feel like I’m missing something super basic. How can I get Lightburn to recognize that what I’m typing is text? In the video someone posted, the example shows exactly the same thing I am trying to do.

In your screenshot, it looks like there’s a green dot in the top left corner of the selection that could be used to manipulate the path of the word Ambassadors. Does it?

Something was done to convert this to paths, and LightBurn no longer sees this as text. If you just type the text you want using the text tool, you should see a blue dot, allowing you to grab it and drag to bend the text. This is an additional way to bend text, and it shows that LightBurn knows this object is a text primitive. Fonts and Text - LightBurn Software Documentation

Apply Path to Text is an option that requires the text to be a LightBurn aware object known as a ‘primitive’.

I’m sorry. I’ve worked on this multiple days now, and I’ve never seen the dot. It always does what it’s doing right now, which apparently means it’s converting it to vector shapes. Is there a setting somewhere that I need to turn off so that it can be recognized as text?

(I just opened a new document and typed a word, but it’s doing the same thing. Still grayed out on the drop-down menu, and no blue dot.)

Hi Rick, do you (or other Lightburn associates) somehow have a way to access my computer remotely? After this conversation ended, I was able to modify text and do everything I had asked about, but I HADN’T DONE ANYTHING DIFFERENTLY. Suddenly, the blue dot showed up and everything worked just like the videos show. I didn’t change any settings on my end. Thank you all for your time and explanations!! I’m glad it works now - but I’m confused about how it got fixed.

No. When you run LightBurn, it will check to ensure the license is valid, but that is it. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.