Hukoer 40x50 DIY Laser engraver

I have a Hukoer 40x50 DIY Laser engraver and having problems it says “Waiting for connection…” in Lightburn
I am connected to the USB port, I have downloaded Engraver Master the software that came with the machine and it works OK with that.

Any ideas I have tried finding machine in devices it’s not there so loaded manualyly on GRBL.

Not familiar with this manufacture. The key bit is the controller and firmware running on it.

You also have “3018 pro” listed in your profile but nothing about how you drive this system. Share more about what you have, and we can direct you from there.

Hi Rick, thank you for your reply, I hope this helps
Capture lb Capture lb2
Engraver Master software

Hi Rick further to my reply, I do have a 3018 pro as well & it’s been working fine, I had laser GRBL which i have today uninstalled, I have just bought the Hukoer 40x50 DIY Laser engraver.

Digging around on the linked site, I find this reference to GRBL:

Have you tried running the ‘Find my Laser’ process?

The most important part is the firmware it’s running. If it uses GRBL, it should work, but it’s possible they’re using a non-standard baud rate for communication. If you can find the specifics about the firmware it uses and how it connects to Engraver Master, that would be a good start.

HI, thanks again looks like it’s now connecting, baud rate 9600. It is now engraving but engraves over prints see photo, is this something I need to do in settings, it all looks ok in preview etc.


That looks like it’s losing position when moving between cuts, which would suggest either the maximum speed setting, or the acceleration setting, are too high. You can set these in the console. Type $$ to see what settings you currently have.

Here’s what the numbers mean:

$110 and $111 are the maximum travel rate for X & Y
$120 and $121 are the acceleration for X & Y