I am getting GRBL error 21 with MKS DLC32


I am getting GRBL error 21 "More than one g-code command from same modal group found in block. " from time to time.

I am connected to the MKS DLC32 board via WLAN (same error via USB).

What I have tried so far with no luck:

  • Using synchronous or buffered connection
  • Using constant power mode or dynamic power mode

MKS DLC32 firmware version is V2.30_H35_2022_1223_N_ZX_001.bin

With buffered connection I get an instant error and with synchronous after a while (when the malicous G-code block arrives at the controller I assume).

Any ideas what I can try?


Go to File->Save gcode, and save the g-code with a .txt extension. Then upload the file here.

This is likely going to be either a configuration or communication issue but let’s confirm.


Wow that was quick. :slight_smile:

Here the G-code export:

BubblesSideIlluminated.gc.txt (2,3 MB)


The g-code looks fine to me which indicates a communication issue. I find it a bit odd that the error would persist across wireless and USB, however.

Can you try loading the gcode to SD Card and running from there?


That worked fine. I tried with another laptop via USB (an older one with less USB power saving stuff I think) and that worked fine as well.

So no more WiFi. But thats okay as long as I have consistent cuts now.

Thank you very much!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.