I am Neje user and i have problem with error17 when i am trying to change to laser mode ($32=1)

Yes that will happen until you can successfully enable $32=1. I hope someone will come along with a solution for you

Here is an old thread, not sure it will help too much, but worth a look

yes i saw it but i still have problems thanks for trying :slight_smile:

Did you make any changed based on the other post? The original poster lists instructions for what he did to make it work.

You need a firmware that has PWM output enabled or this won’t work. Apparently the firmware you installed doesn’t have this.

I would recommend the custom firmware from LaserGRBL:
LaserGRBL/02-v1.1h-custom, XY Homing-20190830.hex at master · arkypita/LaserGRBL · GitHub

1 Like

i didnt make any changes. “The original poster lists instructions for what he did to make it work.” What do u mean by that? where should i instal 1.1h? what should i do with it?

The post where he describes it here:

Now he has a Neje Master 2 whereas you have a Master 1. I don’t know if those lasers get specific firmware.

i think they do thats why u need to use Neje grlb uplouder

This was taken from the feature suggestions. I don’t know whether this is still the case, but doesn’t sound to hopeful


i cant get lightburn to burn with my neje laser. i get error:17 when i try to change $32=1. i heard it may be a pwm problem? can you get lightburn to automatically recognize the neje 30 watt laser??



The issue is with NEJE’s porting of GRBL to the machine, not LightBurn.


Dead Pool

NOTIFICATIONSSubscribeYou’ll not receive any notification about this post.

Powered by Fider




· Dec 2020

That is NEJE themselves - They crippled their version of GRBL firmware on the NEJE master 1. They have apparently improved this for version 2.

okej so i will try to contact neje and ask them for help thx u all <3

Either way I think both Master 1 and Master 2 have Atmega328p based controllers. I’d be surprised if it couldn’t be made to work.

That sounds more like they’d rather sell you a new control board than fix their firmware. I doubt there’s anything in your hardware that makes it incompatible.

If you’re not precious about your laser potentially getting bricked you could probably load the firmware from LaserGRBL and have it work. You should be able to go back to an official firmware if there’s a problem.

I tried to change the firmware, but here there is a problem with the arduino application.
well, I will use the application from neje

You needn’t use Arduino. The person in the linked post simply renamed the file to one of the existing files in the Neje upgrade tool.

This is from github grbl…

Error 17 means you don’t have spindle PWM enabled. Laser mode doesn’t work unless you enable PWM.

The other document probably is more accurate, but thought I’d pass it on…

Don’t know what machine, but it was noted there…


IT WORKED Thank you, I have already lost my hope
but now i have problem with laser power

You mean you were able to flash it with the firmware not provided by Neje? If so that’s great.

But you’ve marked the solution as the one where Neje told you to buy a new board and that this wasn’t possible. That’s super confusing.

Please post the link to the firmware upgrade or instructions that you followed. Others will benefit from your experience.

http://www.neje.club/download/20210601/neje_grbl_uploader_v3.7.exe i used this app and change 1.1f to 1.1h by copy and paste the source code and now i dont have problem with error 17 poping up but the laser dont cut

Fantastic and thank you!

Please start a new thread if you need help with the ‘laser not cutting’.