I am not able to connect laser in Lightburn with Makerbase MKS DLC V2.1 controller

I have a Sculpfun S9. The stock controller board, a Sculpfun XY DLC V1.1 quit showing up as a laser device in Lightburn after I tried to add limit switches.
I purchased a Makerbase MKS DLC V2.1 as a replacement and it registers as a USB Serial controller when I run lsusb but will not show up as a laser in Lightburn.

I have flashed the firmware with the GRBL stock firmware but still no joy.
I’m running Ubuntu 22.04.2 LTS

If you plug in the usb cord then execute

sudo dmesg | tail

Does it still show it’s connected there?

Most of the time I have no problem with USB Ubuntu driver stack, but I have had at least once where I had to fiddle around with it…

It also might think this is a braille device… this might help … not directly at a laser, but an i/o device… I just disabled the service


I’ll check this out! Thanks…

Did you remove brltty? This is a common problem with Ubuntu 22. You can remove it using

sudo apt-get purge --auto-remove brltty

The full documentation and another workaround can be found here: Setting up the software - Diode Laser Wiki I also created a short video of the process and linked it there.

Thanks for the suggestion.

britty wasn’t installed. I tried to configure the laser manually as suggested and Lightburn couldn’t connect. How can I tell which port the usb device is using?

Braille comes standard as far as I know… so I’m surprised it’s missing…


do a “ls /dev/tty*” in the console once with the laser connected and once without. You should see which device is added. You can also use lsusb and dmesg to get more detailed output, but the first should be sufficient.

1 Like

You can route it anywhere using udev


Lightburn still can see my device.
lsusb outputs
Bus 001 Device 007: ID 1a86:7523 QinHeng Electronics CH430 serial converter

[ 196.840507] usb 1-4: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
[ 196.840522] usb 1-4: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 196.840530] usb 1-4: Product: USB Serial
[ 196.843306] ch341 1-4:1.0: ch341-uart converter detected
[ 196.844299] usb 1-4: ch341-uart converter now attached to ttyUSB0

So I see that my device is on ttyUSB0 and I changed to that in LightBurn but still no joy in the console.
Port failed to open - already is use?

Unplug it, then reinsert it, check dmesg for a new ttyUSB* type connection… it’s probably something like ttyUSB1


no, same thing man.
dmesg reports it as ttyUSB0 everytime but Lightburn can’t see it.

I wonder if I should try to drop down a couple of release versions? I am running 1.4.00 just now.

Port failed to open - already is use?

NO Lightburn is seeing it, the error message is that the os is not allowing Lightburn to connect…

Do you have the protection levels set correctly?

Show us the output from the long listing command

ls -l /dev/ttyUSB*


crw-rw---- 1 root dialout 188, 0 May 26 13:20 /dev/ttyUSB0

Man! Thanks for direction.
I ran sudo usermod -a -G dialout $USER

Giving DIALOUT to myself and BOOM!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.