I am really stuck here

can someone please help i am really stuck here i was told to right click on Devices and it worked for a bit but now i cannot get my laser to work and right clicking on Devices is not working so i am stuck, i have tried everything and now i am starting to lose work, so help please.

Connected by USB or ethernet?

i am connected with USB

What laser do you have? (or, more specifically, what controller?)

ruida is what i use

When you say “cannot get my laser to work right” what do you mean? As in, what exactly is it doing or not doing?

  • Does it never connect at all?
  • Does it connect but then files fail to send?
  • Something else?

Do you keep a lot of files stored in the laser itself? They get weird sometimes when they’re full.

Do you restart your computer relatively often? Sometimes leaving a Windows Update half done (IE not restarted so it could finish) can cause al kinds of weird behavior.

i am really getting pissed off with this having to ““Devices right click”” all the time it seems to take longer anbd longer each time, you could be sitting here for ten minutes waiting for it to work, is anyone else having this problem, it has only started in the past 8 weeks or so.

The only time I’ve seen it take that long is if the controller isn’t homed - they take a while sometimes to “break out” of the homing phase, but even then it’s only been a minute, tops. Is it homing correctly when you power it up?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.