I am unable to connect to my Boss Laser, With the Lightburn Software

So I downloaded Lightburn on a MacBook Pro before reading about the FTDI Serial Driver that I needed to have installed along with it when I set up the software. I’ve read now that I need the driver in order for my Laser to even connect to the Lightburn software. Every time I attempt to delete Lightburn then re-download it so I can go through the setup process again to install the driver it automatically just signs me back into my account immediately. I’ve tried to install the driver after the fact, but I am still unable to find instructions to download it and connect it correctly. Right now I’m just stuck because I am unable to use the laser without this connection that the FTDI Serial Driver is needed for.

I’m not sure if our documentation covers the FTDI drivers for any platform but Windows at the moment; I’ll take a look shortly to correct it if needed.

As to your use-case, it seems FTDI has drivers listed on their website for macOS in this chart; may need to match it to the version of macOS you have.

If you’re already in LightBurn, I’m assuming “Find My Laser” is yielding no results? On occasion Apple will include drivers you need with no additional hassle, but I don’t have a Mac in front of me to verify the specific driver you need is bundled. Maybe one of our other staff could fill in that information gap!

Your profile says that you have a DSP controller, if you know which specifically, sharing that information more specifically could help us get closer to a solution if it’s not a driver issue.

Hope this helps :slight_smile:

Can you ‘see’ it using ‘lsusb’ from the command line?

IMHO, if possible, put it on the Ethernet connection, much more dependable and no ‘driver’ hassles.


I’m just not entirely sure where to find these drivers that are included from Apple. I’ve tried installing the FTDI driver via that link you provided prior to this thread and it didn’t work. According to the internet my laser has a DSP Controller, but I am not entirely sure. The model of the laser I have is a BOSS LS2440.

Unfortunately I’m quite limited on my knowledge for these lasers and with not being able to connect I’m totally lost considering this is an extremely common issue with no real one resolution.

I’m also not sure if I am able to connect via ethernet to avoid having to use drivers. I don’t believe my laser has any ports for that.

The best way to connect to a dsp is usually via Ethernet. My Ruida has an internet connection on it and I’m sure yours does also…

Generally the Ethernet is next to the USB for the machine.

Do you have access to your local network at the laser to plug it into the network?


If your MacBook has more than one USB port, try them all. My MacBook works best on only 1 of the three ports.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.