I can't find the ".clb" file

I can’t find the “.clb” file.
I can’t find any that I created myself or downloaded.
I am using Windows 10 Home 64 bit. LightBurn 1.1.04,
I have installed Lightburn on two computers, but both computers are the same and cannot see the files.
The funny thing is that the name of the file I created has “.clb)” by itself.

If you downloaded it, I can’t help you find it. I’d suggest searching the drive.

If you created it, how did you do that?

it’s looking for a .clb file without the training parentheses.

The photos you posted are difficult for me to understand what you are trying to express. What I need to see, is what’s covered up by the right ‘window’, which is the materials library. I don’t read your language so I’m probably not seeing what you want me to see.

If it’s a downloaded library from Ortur then it should be easily read. I can see it on the screenshot, but I have not idea where you are in the file system. I can only assume, you are in the wrong directory/folder.

If you create this within Lightburn via the Material library, it will probably work as designed. Of course you will have to enter all the information.

Good luck


It’s possible that the actual file extension is not what it appears. Can you enable “File name extensions” in File Explorer? This will show you the actual extension. If it’s not .clb you will need to change it to .clb.

Go to View then select “File name extension” in the ribbon.


Also, the filenames seem to be somewhat corrupted. They have an extra ‘)’ and likely 1 or 2 extra copies of ‘.clb’ in the name. You may want to clean that up although they should probably still work as long at the extension is correct.

Screenshot from 2022-05-17 10-36-55

Seems OK… I don’t do windows very well, but I’d assume he’s in the wrong folder… The file name looks ok to me…?

One of the reasons I asked ‘how he made them’ or where he got them…


The “.clb” portion of that name may be part of the core filename, not the extension. Windows by default hides filename extensions. Note that you don’t see extensions for the other files listed. It could also be setup to only hide file etensions for known files but not clear from the screenshots.

I also suspect a problem with the extension because you can see that there were attempts at resolving the filename with duplicate attempts at adding “.clb”.

1 Like

Thanks… another reason I’m not a windows fan… Lets make it easier, and hide stuff…



I am not a good user of English, so I made a video.
Does anyone have a solution for this?

Thanks for the video.

It looks like the filename is corrupted somehow.

Try a ‘save as’ in the materials library and see if that changes anything.

That ‘stuff’ on the end of the filename is a worry.

Is this a multi byte ‘text’ on your machine?

Good luck


Do you have naming issues with any other file type like .lbrn2 or .lbart? This seems odd.

I tried creating a material library using Japanese IME called “MDF_cut.clb” with no issue.

Do you know how that can be resolved?

The extension does not seem to be wrong.


I tried saving and loading the library on another computer with lightburn installed.
There are no strange file names added, but I can’t load the file at all.
Is the Japanese environment affecting this?
The file names are saved in 1 byte characters.

Other file types such as .lbrn2 and .lbart can be opened.
Image files such as .png and vector .dxf files can also be imported.

This seems like a bug.

Can you try changing your “system locale” setting to “English (United States)” and see if this changes anything? This will break any non-unicode Japanese programs so you will need to switch this back but curious if this fixes it.

Thank you for your answer.
However, I tried setting the “System Locale” to “English (US)”, but as before, the file was generated but could not be read.

Have you tried changing your primary display language to English? I don’t feel like that should make a difference but…

Is there anything unusual about how you are running LightBurn or your Windows environment?

I have set “System Locale” to “English (US)” and the country or region and regional settings are also set to “English (US)”, but the file does not appear when loading the library.

I am using translation software to translate into English, so please forgive me if I use rude language.

I just verified the bug. It’s something in LightBurn.

If I change language to Japanese I cannot locate .clb files.

Can you try changing language to English in LightBurn (Language->English) and checking library?


I changed the lightburn language to English and it loaded!
Thank you very much. I appreciate it very much.
Until the software improves, I will set the language to English when loading the library.
Thank you so much.

Glad that’s working for you.

We’ll ask @LightBurn or @Rick to take a look and confirm the bug.

Note that this issue seems unique to Japanese language setting. Doesn’t seem to affect other multi-byte languages like Korean or Simplified or Traditional Chinese in my testing.

When set to Japanese material library files do not show in Load screen and there may be an issue with the name of save files having extraneous characters.


I will look into this - sometimes the translators alter the formatting of the text used by the file system for pattern matching extensions, and that can mess them up.

Edit: That is exactly what happened. They translated the ( and ) characters into the Japanese multi-byte versions, and that broke the code that looks for them. This will be fixed in the next release.