I could use some help troubleshooting CO2 power - it's always 100% no matter where I set it

Sorry this is so long, but details and troubleshooting, etc.

My controller is Ruida RDC6442G-B and my power supply is a ZYE MYJG 100W
(like this: https://www.cloudraylaser.com/products/cloudray-100w-myjg-co2-laser-power-supply-with-lcd-display )

I just yesterday tried my first test after installing a new tube. First task is to scribe a light line to frame some stock. After seeing unexpected (full) power on the 0-30W meter, I then programmed 20% power first, then 10%, then 1% just to see what would happen. No love - it’s always full on. I’m getting 100% power output no matter what power I program in Lightburn. I’ve set my minimum power to 1% just so it stays out of the way, and I’ve checked my vender machine settings and maximum and minimum power are at reasonable levels (99% and 10% respectively). But no matter what I send to the machine, once the laser fires, it’s always at 100% (about 23W).

I did tweak my power supply adjustment pot because it was capped at about 15W and I turned it until it would just reach 23W (because from what I could find, that’s a relatively safe power for my 80W tube). I did have to unplug and re-plug the two green terminal plugs to the power supply (so I could access the pot through the hole), but I would think that if that went bad, it would either fire or fail, not just fire 100%

Other than that, the only mods I’ve done are the physical replacement of the tube.

I’m pretty new to Lightburn, so maybe there’s another setting I’m missing? I’m assuming if you select a layer and set “maximum power” on the popup window for that layer, that’s the power that should be firing in operation?

All I can guess at now is it does indeed seem like probably something got jiggled or something while I had the power supply unmounted from the machine enclosure while I was trying to set the power output pot. Even if I set the maximum power output very low on the controller panel and do a pulse, it still puts out full watts. I have checked all the wiring and it all seems good.

Either I lost the PWM signal from the controller somehow (seems unlikely since I didn’t mess with anything on it other than temporarily unplug the green terminal plug from the power supply), or while I was messing with the power supply, I somehow fried or shorted something fragile so the PWM is always 100% now.

I did use a ceramic screwdriver to adjust the pot, so I didn’t short out anything with the tool, but maybe something else could have happened?

The power supply output pot seems to work fine as it does limit the output of the power supply (I have lowered and raised it a few times now and it responds predictably). But when I try to fire it from the controller, it’s getting nothing but 100%.

Any ideas what I should try next? I have an oscilloscope but I’m kinda green on using it. But I could maybe verify that I’m getting a signal from the controller I guess. Could maybe draw up a test for maybe 5 short lines with varying power on each and see if the pulse width is changing.

Is there some kind of procedure I could do to check things out? I wish I knew more about this, but I guess I might after trying to work this out, whether successful or not.

It would be helpful to at least know what kind of signal the power supply is expecting so I can check whether the controller is outputting something appropriate.

Any help here would be appreciated, so thanks in advance for anything. I’m feeling a bit lost & overwhelmed. Just not sure what to do.

By the way, I do know not to connect my scope to the output that fires the tube, in case anybody got spooked there. I would expect the controller PWM is 5V or at least something that won’t damage the scope… or me.

1 Like

In case it helps (I imagine it does):
I hooked up the scope to the outputs from the controller. It looks OK.
5.1V and changing to various percentages of PWM does indeed output the same PWM as measured by the scope.
The wires were a bit noisy so I added a ceramic cap between them and it filtered it out much nicely without dropping the voltage significantly. I thought maybe the noise might be faking a signal, but after cleaning it up it still does the same thing.

That got me thinking about the possibility that the PWM signal is basically being ignored by the power supply, so I disconnected that wire and pulsed it and, with the PWM wire disconnected , the power supply fired 100%. That must mean something?

Then I reconnected PWM and disconnected “enable” and it wouldn’t fire, which is what I would expect, but there it is.

OK, so it doesn’t look like a controller issue. I could replace the power supply, but before I do, any ideas? Maybe this thing is OK and I’m just too dumb to figure it out? That’s very possible. I mean all I did was tweak the output pot with a ceramic screwdriver, but whatever. I wouldn’t think this is a tube issue, but what do I know? It is a brand new tube, but would something like 100% power flow for some reason in a faulty tube?

Any advice is welcome. Thanks.

edit to add:
One more test done, one more data point.
I wanted to see if some weirdness was going on with the new tube, so I tested it with a Mahoney gauge and it fires well over 80W (yeah, I need to limit that once things are running right). So it looks like the tube functions just fine.

1 Like

OK, just so ya know…
If this happens again, then I will just purchase a non-flaky power supply.

I simply removed the power supply and popped the top off. There was a small piece of what looked like plastic tumbling around inside, but nothing conductive.

I fiddled with the adjustment pot a bit and tested it with the top off. It worked! Hmmm. Carefully put it back in and tested again. It still works! however, the power was waay high, certainly not commensurate of the small amount I turned the pot. I fiddled more with the pot until I got it to a place I can live with for now.

Then the big test - I drew up an array of small circles and put varying power on them. That worked too! So I guess I’ve poked and band-aided the thing to working, but time will tell if it’s a long term thing. I have doubts, but we’ll see.

Anyway, thanks fer nuthin’ :laughing:: But I’ll leave this here in case it happens to somebody else.

My conclusion: good quality power supplies are worth the cost.

1 Like

This is a fantastic troubleshooting path. I was definitely suspecting the controller and signal grounds.

… and your expert analysis was certainly worth the time spent. Thanks for sharing!

Good. I was hoping that documenting this effort might help somebody out in the future, though I’d guess this is a pretty odd (and rare) problem? I’m naturally wordy so it’s not a big deal to type it up.

Today this problem was just nagging my brain and I simply don’t trust my power supply, so I ordered a new one from Light Object. I’ll play with the one it came with until I get the new one set up, but I’m looking forward to the peace of mind I’ll have after replacing it.

The tally is: new tube, new laser power supply, new mirrors, new lenses, built my own mount to add a beam combiner. Almost the whole dang optical train has been upgraded. Hopefully my mechanicals continue to work acceptably. If that starts to go south, I’m gonna punt on this thing and just build one from scratch, but I don’t think it will quite come to that.

The pains of being a newby! I call it “tuition” (I am learning quite a bit after all)

edit to add: Yeah, I’m glad I already ordered the power supply.
I just tried engraving something and the ammeter hardly moves while doing a fill pass even at 60% :roll_eyes: :roll_eyes:
Last night it did seem to have a pretty uneven output scale over input range on the meter. I was suspect but I thought it would work. It’s acting like the output just won’t keep up with the input. The new power supply reportedly has a much better reaction speed (or whatever you call it). It’s a faster supply… plus it probably works in the first place, which won’t hurt any.

I think I can limp it along good enough to laser up some targets for aligning optics which is my most pressing need anyway. I can dork around with that for a few days while I’m waiting on the power supply. Maybe I’ll be up & running soon?

1 Like

The laser fires (pulse) from the console at whatever the ‘max’ power on the controllers console is set.

You are in a ‘test’ mode… power and such is up to you and set at the console.

Assume you have a mA meter and not an amp meter… lol

a faster ‘response’ time… The specs seem rather vague as 90% power <= 0.1 ms or s, can’t remember… :frowning:

Good luck

:smile_cat:

Yeah thanks. I was doing both pulses from the panel and programs sent to it from Lightburn. I’ve done dozens of test firings and test parts by now during troubleshooting this problem and aligning the beam path just previous. I have become pretty adept the past couple days at setting the max power and pulse time on the controller panel and pulsing both continuous and manual timed pulses. Hey, I’m actually pretty good at one something! :smiley:

Here for an update.
I bit the bullet and replaced the power supply. I dunno what makes one betterer than another one really, but the enclosure is a fair bit longer, so I would hope that means more robust innards maybe.
Nice bonus is that the wire connectors and labeling were identical so it was plug & play as possible, i.e. didn’t even have to shift a single wire around. Well I did have to drill & tap for the new mounting pattern, but I’m a machinist so I had the tools and that took three minutes.

Anyway, it does seem to work very well. Nice progressive power adjustments all the way up the scale.
Lasers are back on the menu, boys!

1 Like

So did the lps do the trick?

If so, I’m glad you’re back up and operating.

Take care

:smile_cat:

1 Like

Seems to have indeed done the trick.
For the curious, here’s what I bought (the 80W-90W unit for my tube)
https://lightobject.com/accessories-parts/laser-power-supply/

I would guess there are other good ones out there. The one that came with mine originally was probably a 2nd or something so probably faulty to begin with. I did expect to have to upgrade things like this before I purchased my machine and I don’t mind too much because I’m totally new to this and learning as I go. Kind of an intentional “strategy” if you can call it that.

1 Like