I don't know what I'm doing

I purchased a used Eleks Maker laser engraver. I have the free trial running and this thing is acting very strange. I cannot get the laser to turn on unless I press one of the two red buttons on the controller. Sometimes when I turn it on it won’t even engrave, just looks like a laser pointer. Other times it comes on and burns but won’t shut off. It seems one of the buttons controls the info to the motors because if it’s not pressed the laser never moves. Also, when I tried to verify the firmware settings and type $$ into the console it just comes back saying “ok”. So any help getting this thing up and running would be greatly appreciated.

Which gerbil profile have you chosen?
For my old Eleksmaker -STM is the right profile.
What does the console say during startup?

Hi, thanks for responding. I just got home from work. I will get the laser set up and see what the console says.

So, it said:
Waiting for connection…

Then I chose a different port from the options. Once connected it said:

KA (4 diamonds with ?’s in them)benbox laser 3.1(c) mul 2015.06.06

It currently won’t move unless I press the left red button which also starts the laser firing but the locator button does make it move.
Also, from time to time while it’s engraving it give 3 different errors:

Unknown M2
Unknown M8
Unknown M9

Benbox is not a supported controller type. However, you may be able to flash GRBL to the controller.

HowTo Guide: From Benbox to LaserGRBL (LX-NANO/Nano-328p, CH340, Benbox, DCCduino) · Discussion #1213 · arkypita/LaserGRBL · GitHub

1 Like

Oh man! Thank you so much. Like I said, this is like day two trying to figure this out :sweat_smile:
I appreciate the suggestion. I’m going to give it a shot tomorrow and I’ll let you know how it goes!

I’ve been reading through the process you sent me and a few others and I started to think, “Well, what if I just use the Benbox software.” But I’m on a Mac, so I think that will be just as difficult to get up and running :joy:
I’m thinking I’ll download laserGrbl this morning and try flashing the GRBL firmware since I like the lightburn UI and it will support my next engraver when I upgrade in the future. Thanks again!

LaserGRBL doesn’t run on Mac.

Alternatively you can use HexUploader, Arduino IDE, or avrdude to flash the firmware.

1 Like

HexUploader, Arduino IDE both call avrdude …

If you are comfortable with a cli, I’d suggest avrdude… the others are a gui wrap around for avrdude. Pick your poison…


I’m so green and not computer literate that I don’t know what a CLI is nor a GUI wraparound… I think I’m going to look up HexUploader? How would I go about getting the laserGRBL file to flash to the controller if it won’t run on my Mac?

Oh, wait, what I think you’re saying is HexUploader and Arduino IDE essentially point to avrdude? So why not cut out the “middleman”?

You could download the firmware file to your computer and flash from there:
https://raw.githubusercontent.com/arkypita/LaserGRBL/master/LaserGRBL/Firmware/02-v1.1h-custom%2C XY Homing-20190830.hex

If you’re not comfortable with this I suggest you follow the instructions in the LightBurn video:
Installing Clean GRBL Firmware on Diode Lasers - YouTube

They cover instructions for Mac as well.

1 Like

Ok… Downloaded the .zip files, Got Adruino IDE installed, added the new .zip library and put it into a sketch to upload. These are the error codes I’m getting when I try to upload the firmware to the card.
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x62
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x65
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x6e
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x62
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x6f
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x78
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x20
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x6c
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x61
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x73
Failed uploading: uploading error: exit status 1

It also seems like the laser may be having connectivity issues, I know I am selecting the correct port, because I open up LB and the laser will move and the software is running when I put a location in.

It also gives this note at the front end:
Sketch uses 29586 bytes (96%) of program storage space. Maximum is 30720 bytes.
Global variables use 1633 bytes (79%) of dynamic memory, leaving 415 bytes for local variables. Maximum is 2048 bytes.

I think I may have had the wrong file trying to upload as firmware. It was not lines of code but the description of the zip file and what it does. I tried a different file and it shows these error codes now:

In file included from /Users/Daddy/Documents/Arduino/libraries/grbl/config.h:30:0,
from /Users/Daddy/Documents/Arduino/libraries/grbl/examples/grblUpload/grblUpload.ino:1:
/Users/Daddy/Documents/Arduino/libraries/grbl/grbl.h:68:4: error: #error “Required HOMING_CYCLE_0 not defined.”
#error “Required HOMING_CYCLE_0 not defined.”
/Users/Daddy/Documents/Arduino/libraries/grbl/grbl.h:108:4: error: #error “WCO refresh must be greater than one.”
#error “WCO refresh must be greater than one.”
/Users/Daddy/Documents/Arduino/libraries/grbl/grbl.h:111:4: error: #error “Override refresh must be greater than zero.”
#error “Override refresh must be greater than zero.”

exit status 1

Compilation error: exit status 1

These are compilation errors, not upload errors… There should be a .bin or .hex file somewhere… This is precompiled code.


The LightBurn documented approach links to a zip file. Their method has the user create and upload the sketch in one go which is common for Arduino IDE.

Can you confirm that you took the LightBurn zip file as a starting point? Did you follow the instructions exactly?

I followed the google drive link and hit the download button, it didn’t seem to be downloading as a .zip file though.

I can neither confirm nor deny that I followed the instructions correctly, I’m guessing I didn’t. :sweat_smile:

I downloaded the file earlier to make sure it was working so should be good there. What do you mean it didn’t seem to be a zip file? And did you end up using the file?

When I tried to follow the YT instructions as I watched my files just come up in a file folder and I ended up having to compress them in order for the Arduino IDE to add the library. I may have done this incorrectly?