I keep getting this error

Hi Oz,
So I just finished the burn and the machine went right back to the X Y zero origin.
However, when I click on the “get origin” It still reads the same.
Right now I’m just happy that its doing what its supposed to do.

So I just started another burn, let it run for a couple of minutes and stopped it.
I clicked on the “go to origin” and the machine did exactly what it should.
It looks like you fixed my problem.

You’ve been a great help in solving my problems.
But now I have another question.
If my origin is now working as it should, and I click on the “Get origin”.
Why does it still show the my machine is out of position?
Shouldn’t it read all zeros?

Where is the laser head when you click that?

Hi Oz,
I click that after the laser has moved to the X Y Z origin. (which I have set as X-0 Y-0 Z-0)

Type ? In the console and enter, then $# and enter. What do they output?

Currently I am not hooked up to my machine.
It will be later today when I will be able to get out there.

Hi Oz,
This is what I get back.

  • First command should be ?
  • Second command should be $#

You mistyped the second one.

That said, I can see what I need to - Your WCO (world coordinate offset) is wrong. It should exactly match the travel length of your X & Y axis. So if your machine’s $130 & $131 settings are 790mm each, for example, the WCO values should be (-790.0, -790.0, zzzz). They aren’t, so you aren’t properly zero’d.

Hi Oz,
Is this where I make the change?
If so, I would enter -540 for both X and Y?
I also attached my current setting for both the laser and CNC

Or, do I add the change in the macro?

Hi Oz,
So I tried to enter (what I believe to be the correct Information) in the macro, but the controller doesn’t seem to want to accept a negative number.
What am I doing wrong?

The link I sent in my very first reply here contains the command you need: Common Grbl Setups - LightBurn Software Documentation

G10 L2 P1 X-540 Y-540

You add that to the ‘User Laser’ macro.

Thanks Oz,
However, now when I click the “get position” this is the result.
Also, when I start a job I now get the “out of bounds” error.
Before adding this command, I did not get that.

Please send screen shots of your whole screen. I can’t see anything useful from just this. You’re also telling me what the machine is reporting as it’s current position, but not telling me where the machine physically appears to be, so I can’t tell if those numbers are correct or not.

I suspect that you’re using a starting mode other than “Absolute Coords” and/or haven’t properly set the User Origin value since changing the machine offset.

Hi Oz,
I cant help but think that I’m explaining myself right.
So I’m attaching a couple of pictures of my machine.
The first one is the whole machine and you can see the (fixture) clamped that I use to burn tiles.
As an example, I’m currently doing 10 tiles with the same subject matter, so I can simply switch
out the tiles to the bump stops and start it again.
The second picture is a close up and also shows my X-0 Y-0 start point.
I always use “User origin” and the lower left hand corner. (no matter what my project is)
Please don’t get me wrong, you have solved my problem regarding the laser not going back to the
start position and the “out of bounds” error.
However, since I added the G10 command to the laser macro, I now the out of bounds error again.
I may take that out so I don’t get the error message anymore.
A couple of posts back you asked me to click the “Get Location” and report back.
My machine is working correctly again and I really don’t care what it reads in that command.
I’m only curious as to why it would not read all zeros.
I hope this helps.
Sorry for the long winded post. (just trying to learn)


No, it’s really not. This is:


The corner you showed above would be your User Origin location, assuming you’ve set it, which is not the same thing.

You can use it the way you’re used to if you want to - it’ll work - but you’re doing the equivalent of trying to use the claw end of a hammer to drive nails. That’ll work too, but it’s really not how it was intended to be used, and isn’t going to work nearly as well as using it the way it was designed.

Jog the laser to that X/Y 0 point you marked and click ‘Set Origin’. Then set the Job Origin button to the lower-left dot, and put LightBurn into User Origin mode. Your coords will still read wherever that point is relative to the true, physical origin of the workspace in the front-left, but the jobs will start at the point you specify, and that will stay the set starting point until you change it.

That is exactly how I do use the laser, and right now its working perfectly.
I think we have beat this issue into the ground.
Thank you for all your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.