I need help with a few problems I am having

Last week I got a 3018 Pro and I installed LightBurn. I’ve only been using the laser and there’s a few things I can figure out. I am trying to figure out how to speed up the burn time and my images are kind of blurry. I am burning onto a piece of wood. I think the reason the image is blurry is because of how slow the unit is moving. Can anyone help me with this?


The laser will not fire from the controller when I change $32 from 0 to 1. Is there some thing else I need to do?

I tried running a burn with 32 set to one and the laser turns on but it won’t burn the wood.

Paste your $$ settings here.


Those numbers are the maximum speed your controller is allowed to go. If you are setting it to move any faster than 1000mm/minute (16.66 mm/sec) then the controller will reduce the beam power to compensate for the lower speed, so you end up getting the amount of burn you asked for.

For example, if I ask for 6000 mm/sec, at 100% power, but my laser can only travel at 1500mm/sec, that is 1/4 the speed I requested. If I move at 1/4 the requested speed, but still at 100% power, it will burn too much, so the controller drops the power to 25% as well, so the output matches the actual speed.

It also looks like $32 didn’t stick at 1.

When I change 32 to 1 the laser won’t fire with the remote and the laser is to weak to burn the material.

“The remote”? Also, regarding the ‘too weak’ comment, read what I wrote above. You haven’t said yet what speed you’re trying to use, what you’re trying to burn, what power you have it set to, or much other than “it’s too weak”.

  • Have you focused the diode? If not, this would be a problem.
  • In Edit > Device Settings in LightBurn, check to make sure that the ‘S-Value Max’ setting is 1000, to match the setting in the controller. If it isn’t, that would be reducing your output power as well.


That’s the remote.

I slowed the laser power down to about 4% and the speed is around 300. The burns look better, but I have another question. When I do the image trace and try to burn it I get lines on the image from where it switched paths. Is there a way to get it to stop doing that?



</fifteen characters>

</fifteen characters>?

I can’t create a post that’s less than 15 characters in length. Are you even going to read this?

Yes I am. I can’t get it to burn when I put $32=1. I have tried refocusing it.

Then you have an issue that ISN’T the $32=1. Likely the s-value max, or your acceleration settings. But, this has all been said already, so that’s why I asked.

I’ve changed the setting as recommended and the burns look better and are not as blurry. The only other problem I have is that this leaving the lines where they shouldn’t be when I burn a image trace.

$32=0 is “spindle mode”. It means that the controller will pause each time the PWM output is changed, because it assumes you have a rotary tool (spindle) that needs time to speed up / slow down to the requested RPM. It also will not disable the PWM output when executing travel moves because it assumes the spindle is retracted.

$32=1 is “laser mode”. It eliminates the pauses when the PWM output is changed because lasers respond to this instantly, and it disables the PWM output (IE the beam) during travel moves.

Note that this requires GRBL 1.1f or later firmware. If your GRBL version is older than 1.1f, you would need to use the GRBL-M3 device in LightBurn, which emits different GCode that manages the beam output directly, instead of assuming the GRBL will turn it off/on for you during travel / cut moves.

I reflashed v1.1 and now it will burn with $32-1, but the controller will not turn on the laser. The controller give’s me full motion controller and a button to turn the laser on. For some reason it won’t let me fire the laser when $32-1.