I sometimes get issues saving files mid editing, maybe related to license issues

Hi,

I’ve been using Lightburn for a couple of months now on Linux/Manjaro.
Sometimes, Lightburn would ask me to re-enter my license. Not sure how it forgets. Maybe it’s happening periodically?

Anyway, this is not the issue. The issue comes, when it decides it runs out of a license in the middle of editing:

  • I work on a piece and press save in between in case something goes wrong.
  • Then when I want to start cutting or want to close the application, I notice something strange:
  • When I want to start cutting, nothing happens
  • When I want to restart the application it asks me if I want to save my files… strange, I did just save it. I say yes, and nothing happens.
  • Then I notice: Saving or sending anything to the laser doesn’t do anything in this weird bug-state.
  • So nothing else to do but close the application and restart it. After that it would usually ask me to re-enter my license. I do that and do all the changes all over again that had not been saved.
  • I start cutting and it won’t work. But at least saving works, so save file, restart Lightburn and now it works again.

So I thought, maybe the bug has been fixed and I check for updates. It tells me, that something with SSL is not working. Anyway, I got the installer manually and updated to the latest version today.

A couple of edits and saves worked fine, but when restarting the application, it asked me to re-enter the license again. I do that and start working. At some point, I notice, that I can’t save the file anymore. So I restart Lightburn, expecting the License dialog to pop up, but this time it didn’t.

So to sum up:

  • Lightburn keeps forgetting my license
  • When it does so in the middle of software use, I can neither save nor tell the laser to do anything. I can, however, continue editing without ever being told that anything is wrong. I would expect the exact opposite: No more editing (aside from undo/redo), but saving should always work! It’s really annoying losing all of the progress.
  • After entering license info, some parts of Lightburn do not find out about the license being present and as such saving and cutting are disabled until the next restart.

Anyone else noticed this behavior?

I only found one similar topic, which was never answered:
https://forum.lightburnsoftware.com/t/files-not-saving-in-ver-1-0-04-win-10/52478/2

The SSL Error when checking for updates was fixed with the latest version, but that was the least of my concerns.

In what Lightburn are you getting this issue?

Lightburn 1.6.01, GCode

Lets see if @berainlb or @jkwilborn have more insight in the matter.

1 Like

Usually this means it’s not writing the data somewhere … like a protection violation or something along those lines. Lightburn is rather verbose when it fails, so I wonder…

I don’t know how the licensing works, so I’m just guessing…

I’d search my drives, displaying the file name and protection setting on them… I think they use .lb* type extension.

Something like this command line from a terminal

find 2>/dev/null / -iregex ".*\.lb.*" -exec ls -l {} \;

Maybe @JohnJohn can suggest something to help isolate where this is occurring.

:smile_cat:

1 Like

Files that match *.lb*:
~/.config/LightBurn/presets/material_test_presets.lbmt

A ton of backup files for preferences:
~/.config/LightBurn/backup/prefs/<date-time>.lbprefs

And my lightburn files (*.lbrn2).

That’s it. Nothing that looks even remotely like a license file.

Don’t know if it’d be a license file so to speak… I have no idea where it might put this and it’s probably not public information… you’ll probably have to wait until one of the Lightburn people drop in.

:smile_cat:

1 Like

Is there anything unusual about your Linux installation? In particular, do you have anything that would dynamically change aspects of your system configuration, perhaps with virtualization, containers, or remote home mount? Are you using removable drives, a cloud drive solution, or possibly network shares?

Sounds like something is triggering the fingerprint for your installation to change such that the License scheme in LightBurn is detecting a new installation. It’s not clear to me that the license issue is causing the other issues or if they’re both caused by the same underlying condition.

I don’t have any mounts that change. No network mounts or cloud stuff. I haven’t plugged in a USB drive in ages.
What I do regularly plug in and unplug is the USB Hub, to which the laser is connected.

I do have dual boot set up, but I rarely boot into windows (mostly for bios updates). Not as often as this problem appears at least.

Manjaro is a rolling distro, so updates to the OS are more frequent. Though I don’t do them that often either. And I’ve certainly had to re-enter my credentials twice without an update.

I can live with the fingerprint change being triggered every now and then and having to restart, but not being able to save is very annoying and wasting time.

Let me know if I can give you some debug logs or anything.

If this were to happen, I think you would run out of seats quickly as each fingerprint would represent a new “computer” from what the servers can see.

Could you write to support@lightburnsoftware.com and expose the issue as well as here please?

2 Likes

Thanks, done

1 Like

3 posts were split to a new topic: Laser Falcon 10 w - GCode no longer outputs

The problem with the software not allowing you to save if the license info wipes is a known issue, and has been fixed already for the 1.7 release.

The problem of your machine constantly losing its license info is something I haven’t seen before. The license system uses a bunch of different information to produce the fingerprint it uses for licensing, so if you’re changing “enough” stuff in the OS to cause a fingerprint change, that could be license issue. The problem of not being able to save work has been addressed, though I don’t have a release date for 1.7 yet.

Fwiw, Manjaro is not one of our officially supported distros.