Icon/button Size In the lightburn software

I just got light burn to try love it already. On my other PC it runs fine. Just put it on my new PC and I believe with it being a high resolution screen all the buttons in the software look small. Any fix for this?

I know this was an issue before. I might have seen it on the fb page.

A quick google search pulls up this:

If you know how to set your environment variables, you could try adding

QT_AUTO_SCREEN_SCALE_FACTOR=1

If you don’t know how to set your environment variables, you can go to control panel in windows 10, and type ‘environment variables’ into the search, and it’ll take you where you need to go. Click ‘new’ and type in the info like such:
image

Then you’ll likely need to restart LightBurn.

I don’t know if any of this will work, but it’s worth a shot.

There’s this slider in Edit > Settings:
image

It’s likely not made it into the documentation yet.

1 Like

Thanks Blake. That was a little over my head. I got into those setting was not sure how to execute the fix.
Thanks OZ that helped. Although for high resolution screen you guy might want to think about making them even a little bigger. :smile:

Yeah, don’t listen to me. I didn’t even know that setting was in LightBurn. Probably because I can’t talk my boss into letting me get a couple 4k monitors for work. :frowning:

Done - I had another request for this as well, and it was an easy change.

Some thing else I noticed. The buttons changed size but the colors on the bottom of the screen did not.

Thanks OZ
This is what it looks like with the setting set to very large

I don’t think they were included in the resize list, but I can change that.

1 Like

Scaling the navigation buttons would also be helpful. On my 12.1" touchscreen those are super tiny, there is a lot of unused space. Makes it hard to use as touchscreen.

I assume its a function of the 12.1" screen set to the recommended 2736x1824. It makes all the text and toggles super small.

You can change the tool button size in the settings here:
image

That doesn’t change the text scale though. For that you can set an environment variable called QT_SCALE_FACTOR or one of the others mentioned here: https://doc.qt.io/qt-5/highdpi.html#high-dpi-support-in-qt

Sorry I should of specified that I did change the size to very large before I took the screen shot. Changing the slider does not change the size of the movement buttons just like Petr mentioned with the color bar.

Thank you for all your help.

Using the QT_SCALE_FACTOR noted above changes the whole UI, so for really high res displays that are very small, that’s probably a better choice.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.