Icon Previews not working

Hi…Was just wondering if there is something wrong with icon previews? I thought I read that this was a new feature in the latest release. Is there something I need to do to enable this? I’m on the latest release of Windows 10


Only files that have been saved since the new version will show icons, and only vector data within those files (until the next release).

There are still issues with it on many systems, and it’s nearly impossible to debug it because it hooks into the OS where I can’t easily inspect it. I’ll be trying to look into it more soon.

Thanks for the quick response :slight_smile:

FYI, This new feature does not work on my Win10/64 machine.

FYI, This new feature works great on my Win10/64 machine.

1 Like

Yup - I have found no consistent pattern for it not working. This is a weird one.

I have no idea what changes, maybe latest win10 update?, but today my lbm projects icons reflects the project.

Really cool!

did you install or uninstall something else before the icons shows the preview?

I did install couple of video editing sw.

What i did find out is that this preview feature works when there is no software associated with lbrn files.
so, it’s either no sw associated and you can’t open these files by double clicking on those (you can however drag and drop these files on a running instance of lightburn ) - in this case i can see the icon preview.

If however, lbrn are associated with lightburn app - no preview and preview is showing lightburn’s red dragon icon instead.

Thank You, great find!
I deleted the .lbrn association in the regedit and now I can see the preview :slightly_smiling_face:
Maybe it´s a clue to find a solution where we can see the preview and the software association remains

well, the files are associated again and the preview remains, even after restarting the computer
I need to point that before the association was deleted I previosuly installed the security update for Visual C++ 2010 Service Pack 1: August 9, 2011 from windows update

The preview remains until you re-save your work which in that case the red dragon will eat it alive!
At least in my case. if you solved it and you have lbrn associated with lightburn and you can save a new project with preview icon then please come forward.

Yes same for me… after re-save the project the dragon eats the preview from this project :dizzy_face::upside_down_face:

That’s a good clue - I will have a look to see what’s different between those two. It’s very strange, as it does work on some systems, just not all. Which entries in the registry did you delete, specifically?

deleted the UserChoice folder at HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.lbrn\

That’s bizarre - I didn’t create that one. Did you? (at some point did you tell Windows to use LightBurn to launch lbrn files?)

is automatically created after select lightburn as default program to open .lbrn files

You should never have to do that though - LightBurn does that by itself when you run it. That might be the entire issue.

LightBurn creates these entries by itself:

HKEY_CLASSES_ROOT\.lbrn - REG_SZ  LightBurn.LightBurn.1
HKEY_CLASSES_ROOT\LightBurn.LightBurn.1\Shell\Open\Command - REG_SZ  C:\Program Files\LightBurn\LightBurn.exe %1

And there’s one in there to do the thumbnail extension too, which is installed when you install the app. The other two are done when you run the program.

Edit: I think I know what’s going on. This helped - thank you.