iCube Homing issues


I’m having issues with the Sculpfun iCube when it comes to homing in Lightburn, etc. I thought it was meant to have limit switches on both Axis but mine will grind against the sides when trying to home, etc. Is there a correct way to set home? I have turned the machine off and moved the head to the home position, switched on but when pressing home the machine will grind to the corner…this is making it difficult for me to get layouts correct as what I’m seeing on screen is not the position that the machine will use, so I have to just keep framing until I can align it.

Any help would be appreciated as I’m out of ideas.


It should have homing to front/left

You might need to have a look inside to see if anything is unplugged from factory

I looked at the user manual. Although I saw a Home symbol in the phone app, I saw no mention of Homing or limit switches. I am guessing it does not have limit switches.

In the Laser window, select Absolute Coords.

If no limit switches, in the Lightburn Console window, enter $22=0. In the Lightburn Device Settings window, turn off Auto-home on startup. (If it DOES have limit switches, do the opposite, auto-home on and $22=1, and ignore below.)

Move the laser head (jog or manually) to the desired Origin (0,0) location. This is typically the front-left corner. then click the Set Origin button in the Move window.

You should be ready to go now.

all reviews i checked, even their own marketing shows homing cycles
Unless they removed them afterwards

Interesting! Are you sure it was Homing and not a Go To Origin cycle?

Was there a video showing it coming off the switches?

Their own
With timestamp

Cant argue with that. It has switches.

It appears you have a GRBL parameter settings issue. Is this a new machine or a new problem on an old machine?

It’s a brand new machine…I’ve checked internally and nothing is loose…it does the grinding thing even if I use the Home button in the app…

Can you show a video? In which direction does it try to home? Open the top cover, then you can see what it is doing during the homing cycle.
Sometimes, the cable of the laser head is mounted such that it is too short, the mechanics can’t reach the limit switches then.

OK, I’ve got to the bottom of it. I opened it up to check the limit switches, everything looked ok but I disconnected everything, used a bit of contact cleaner and reconnected. I also snipped a cable tie that looked like it was putting unnecessary strain on one connection and now all ok.
Looks like QC isn’t a priority with these, worth noting for anyone else who may have issues in the future.
Thanks for all the great replies, makes a change to get useful responses unlike the usual gatekeeping that goes on in most tech forums these days…much appreciated

1 Like

If you could maybe take a couple pictures to identify where the problem was, might be useful in future for other users.

Nice job figuring it out

It’s explained here in the mechanical setup section:

That’s a great article, covers everything I found as well…thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.