Idle fault, how to stop this

I am trying to raster a poster, and have received this fault code quite a few times.


Each time the laser stops moving, and stops burning. The machine will not move afterward, until I unplug, and plug it back in. I know the numbers in the code are co-ordinates.
Can anyone tell me what the problem may be?


That isn’t a fault message, it just looks like the controller stopped. It would be useful to know what you actually have and what you chose as the device type in LightBurn.

Actually, based on what you just posted on the other thread about getting an out of bounds message, perhaps your cut is going out of bounds, like the software is trying to tell you. That would trigger a limit fault and halt the job.

Sorry, I have a chinese blue and white TS-4060 with C3D board. I was rastering with the acthinson (spelling?) as this seems the only one that doesn’t shift on me.

but I am not sure how to fix either problem. I tried putting the origin in every corner, same out of bounds error. And, as I said in the other post, i am cutting in the middle of my machine. It is a 5" X 6" piece of wood, in a 25.5" X 17.75" bed. So no where near out of bounds. I also tried setting the finish origine in the center, just to make sure it wasn’t out of bounds either… still no luck

The shift you’re referring to is from running Smoothieware too fast during image engraving. If you’re trying to run it above about 80mm/sec with the default DPI setting it can’t keep up. If you plan to do a lot of image engraving, I’d suggest switching to GRBL-LPC firmware, which is about 3x to 4x faster and runs very well.

You can also try using Newsprint dither - it’s a little blockier, but it’s designed to reduce the GCode density to help Smoothieware keep up.

Thank-you, I will try that.
Anyway to get rid of the out of bounds??

Move it away from the edges? I can’t see what you’re cutting, where you’ve placed it, or what settings you’re using. Without that info I can only make very general suggestions.

Just for clarification, this is where the laser stopped with the idle notification. As you can see, no where near being out of bounds

Have you changed the settings in the config file on the C3D to set the proper machine size?

What coordinates is it telling you when you click “Get Positions” on the Move window?

I have not changed the size on the config file. I was just looking at it, and i still don’t see where to change it, but i will ask that on the Cohesion forum.

I believe this is the problem though, as when I “get position” X=12.324 Y=15.622, and it’s not even half way up the board.

Thank-you for your time. I really appreciate it.

In the config file you’re looking for alpha_max and beta_max. They’re the names Smoothieware chose for X and Y some reason. By default they are 300 and 200, which is appropriate for the K40, but not for your machine

When I was setting up the C3D board, I received some help from a guy whom has the same machine as I. He gave me setting to change on the config file. The alpha_max and beta_max settings were already changed to 600mm and 400mm, so, unfortunately, this is not the solution.

There may be other things you have to set as well. C3D should be able to help you get that sorted.

Thank-you again, at least I’m on the right track