Ignore empty fields in variable text

Hi,
I am using variable text for producing garden labels. Not all fields in each label contain data. When i engrave the label, a symbols is added where there is no data. Is there a way to ensure that LB ignores the empty field and moves to the next field that has data?
Many thanks in advance,
Ben

Can you please show what this looks like?

If I have blanks in my CSV table, nothing is produced for that variable and left blank.

Note the blank cell for that data in record one of this file. This is the slot for CSV variable %3 (counting starts with zero).

And when resolved within LightBurn, you will see that it is left blank as there is no data to fill that slot.

Show us what you get, and we can go from there. :slight_smile:

So. on the preview, I get the same result as you, but when I send it to the engraver (Ruida), it inserts " and engraves that. Does that make sense?

Not really. Show us some screenshots to illustrate what you are seeing.

Edit: Re-reading, I see you say that this produces the " mark. Quote marks are used to help manage the text output, so you may have them set incorrectly in the CSV file to produce the result you are after.

Variable Text Formats - LightBurn Software Documentation - Any sequence of characters enclosed in single quotes will be included verbatim in the output string (stripped of the quotes), even if it contains formatting characters. Two consecutive single quotes (’’) are replaced by a single quote in the output. All other characters in the input string are included verbatim in the output string.

I’m updating the software today, so will try again and see if it happens. Thanks for the reply.

Hi,
I upgraded the software to the latest version, which meant I lost all my settings. I have got most of them back and the " issue seems to have disappeared. However, I have set the scanning offset , but it doesn’t seems to help, as I’m now getting doubles of everything. In other words, a V when engraved comes out as VV. Do you have any suggestions to overcome this at all?
Many thanks
Ben

As I said above, need to see what you are working with and the results you are getting. Post the LightBurn file and show an example of the CVS file that you are having issue with, and we may have something more to offer. :slight_smile:

Hi,
The csv file is fine and the process to create the variable text merge is also fine. It is when I send it to the engraver it goes wrong. Not great photos, and ignore the backwards text as I have corrected that, but it’s the double image that is the issue:

Engrave 1Engrave 2

I did manage to get a great one down, but didn’t save the settings. Now I get the blurred/double image you can see in the reversed Embothrium coccineum continuously.

Hoping that clears it up. My machine is a Ruida 644xs.
Thanks
Ben

So now I am confused. The title of this post is about “empty fields in variable text”. Has that issue been resolved? Are these variable text objects producing as expected now?

I want to ensure resolution to the first issue before moving on to another, unrelated issue. :slight_smile:

Hi,
Yes the original issue does appear to have resolved as far as I can see. Not sure how, but it’s fine. However, now I am getting the blurred/double line when I actually engrave the label, which is not improving when I use the variable offset.
Thanks
Ben

Not sure what you are saying. :slight_smile: As mentioned, it is best if you include a specific example of what your result looks like. We are not there to “see” what you are observing, so difficult to fully understand the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.