IKIER 24/48 Pro Max

Well…I bought it. Was hoping for more speed for cutting 3mm and 6mm wood projects. Usually that is the case, however, not always. Why? Well something is not working exactly right. I’m not sure if it’s an issue with lightburn (highly doubt it) or something else.

The first issue was a really high variation between the exact same material tests on the same piece of wood. At times, I was amazed…others not seeing a noticable difference between a 10 watt and 48. Hmm. Well, after wasting alot of material with testing, I burned a couple slate coasters, and yes I know all materials of the same kind may burn different, but they should never be THIS far off. It was night and day at same settings.

I did 2mm basswood and 3mm birch plywood testing…again all over the place. Maybe me? Checked and rechecked…some good, some terrible. It was random. But the biggest issue is that (and thankfully they have limit switches on all 3 axis), now at same settings I cut at some are unreal. Great. But…errr…no. sometimes the laser head will slam into the rails…yes the limit switch shuts the stepper motors off…but as to why it’s random for same settings? I have no idea. I am not an expert, but I do understand the basics, and for this to be so random…well I’m stumped. I’ll reach out to them tomorrow and see what they say. Something, at least with mine, is wrong.

Also my control board wasn’t attached to the frame, and no screws to do so myself. I get it, not a big expense to buy 2 screws, but wondering about quality control now. Not exactly a cheap laser. Anyone else have any issues?

Lots of QC issues with my Pro. Nothing I couldn’t solve. Their support is pretty timely (about 24 hours turnaround) but not very helpful from my experience. Maybe you’ll have better luck.

My Pro has been really, really consistent since I got everything working right.

  • You need to check every single screw, belt, and guide for tightness and alignment. Every one. I found MANY…frame attachments, motor mounts, pinion/pulley, rails/rods, etc. Remove all trim covers and check the fasteners hidden under them. Run every axis full length by hand checking for looseness and binding.
  • Run the y axis cable bundle to the outside of the mainframe.
  • You may need to cut the sheathing off the Z axis cable and reroute. The branch that connects to the focus switch and crosshairs was about 5mm too short on mine. Re-route fixed.
  • connectors and cabling inside the gantry may interfere with the belt or rail car/carriage. You may need to fiddle with it a few times to get it tucked in there just right.
  • My Y rods fell out in shipping. One was bent. Complete rebuild there. Next time I need to do a teardown, I’ll likely replace them and the bearing with Misumi parts.
  • My Z rods were flopping around. Complete rebuild there.
  • Gantry belt was preset but too loose.
  • Crosshairs were not square to gantry/module. Easy fix.
  • No firmware for extension kit. Easy fix to get up and running Lightburn, but no solution for offline/touchscreen control. Multiple emails with no resolution.
  • other firmware oddities I’ve documented in my assorted K1 topics. Feel free to search.

Oh. If you don’t have your own set of quality metric drivers, get a set. The included ones are typical soft steel junk and will wear out and/or ruin fasteners before you can check the entire machine. I like Chapman, Bondhus, and Wiha, but even Kobalt or similar big box brands are an upgrade.

For this machine…just gantry needs to be installed. 4 screws. Attach 4 connections and 4 screws to attach top plate. Yes you CAN adjust whatever needs to be…but again my issue is not hardware at all. Besides control board not mounted. It is the random results from material tests which leads me to believe there is a mis-communication between board and computer. Maybe not. I’ll run more tests tomorrow. Right now I just need to call it a night or there will be a $1600 pile of junk outside. It seems to just decide on its own where to go and what power regardless of settings. Kinda not impressed. Might be me, but don’t think so. When it does work…love it. When I get random BS from it, not so much.

The randomness is troubling. Possible communication issue or faulty main board.

How are you connected? I’ve been rock solid with a high quality (Anker) USB A-to-C from my Win10 laptop.

Firmware up to date? I understand there is a new one from July. I’m still on 1.433 from August. Waffling on whether I should update, since I’m running good now. I sent an email to support yesterday inquiring about a change log.

There’s another user with a ProMax that was having odd autofocus behavior and discovered it worked fine thru the touchscreen. He deleted and rebuilt his LB Device manually and now he’s running good.

Is your randomness repeatable enough to save a test GC to run offline and see if it’s a comm/device setup problem?

Ligjtburn wouldn’t recognize it so I manually added it as a grbl device. I’m not using the touchscreen because this machine is so huge I don’t have room in my (homemade) enclosure to fit it in. And really see no use for one with setup I have to use anything but LB. I’m just using the included cable for now. Only had the machine for 3 days now, but I don’t believe its the cable.

I had an issue with autofocus…but it was me. I love the LA hobby guy…but I didn’t pay attention when he corrected himself about which settings need to be on for then z axis. After 2 hrs, I rewatched and saw he corrected it on screen, but not verbally.

What’s extremely troubling to me, is that I tried to frame in dead center of work area a 3.5"×3.8" (size of x-mas ornaments I really need to get done) and it would send the head at high speed into either one of the side rails or bottom. Same settings, random direction. It really might be me somehow. I need some more coffee and will try again in a few minutes.

I never use the touchscreen either. (Nor the crosshairs). I just suggested it as a troubleshooting route.

I use absolute coord. Red and green LB origin glyphs overlap in lower left corner of workspace.

  1. Home machine. I have LB set to home on connection
  2. Jog to workpiece using LB move buttons, then autofocus macro.
  3. Frame to fine tune workpiece position
  4. Run job.

I send the head to 410, 750 finish position.

I can do step 4 alone all day on dozens of workpieces without subsequent framing if I have a jig set up.

Well 3 cups of coffee later and one prob solved. Do NOT use frame if using the cross hairs. Even with the offset enabled, the laser will start at the laser head, not cross hairs. In my case, 53 mm difference. I’m still having moving issues though. After homing I sent machine to center, auto focused and tried to use the pin function again to move the laser close to my starting point. It moved in opposite direction then froze up and I had to restart LB and the laser…twice.

Also still power issues. On my material test, one pass at 1000 mm/min 60% power (yes that sounds very fast) easily cut through this 2mm birch plywood. I set it to cut at 900 mm/min at 60% and not even close. Makes the material test useless. It may be the material itself is different from one piece to another…but I’m not sure. I’ll keep trying.

Hopefully somebody more savvy with LB setup can stop in to help. I’m still learning and would hate to send you in circles.