Ikier K1 on Manjaro Linux

Hi, first post here.

This not a question anymore, but I thought I’d write down my first issues and how they’ve been solved.

So I got myself an Ikier k1 pro 24w. This is my first laser, so I was a bit unsure what to expect. I ran into some issues and this is the story of what I did to get it running.

Short story:
I think it had to do with installing the android app or the driver on windows 7 and then following How to: Lightburn on Linux Manjaro, USB, Atomstack X7 PRO

The long story:
When I first turned it on (after spending 2 weeks on an enclosure), the power button only lighted up shortly. I thought it might take some time to boot, but it seems, that the mechanism is a bit faulty and only locks in sometimes.

After that, I tried running lightburn (on Linux, Manjaro) and let it find the laser automatically. No success. Tried manually adding it as GRBL. Device created, but the “choose” menu had no options for the port. Since there is no linux driver on the stick or homepage, I stopped on linux for now.

I went to windows 10 (have it on dual boot for bios updates mostly). After installing the driver, I did the same steps as on Linux, without success. It was weird anyway, that windows would not do a sound upon plugging in the USB cable. I tried different cables and ports. No success.

Well, okay, I thought maybe at least the app would work… and for some reason it did. I was able to move the head :partying_face:.

Digging up an older laptop with Windows 7, I did the same steps as on win 10 and it worked. I could move the head!
The screen resolution with that older Laptop was really bad, so I gave my current laptop with Win 10 another chance and for some reason this worked too now. Maybe something was triggered in the device, either by the android app or by the successful Win7 run :thinking:.

So I had high hopes, that Linux might work too now. I switched to linux and after starting Lightburn, I saw “ttyUSB0” in the port dropdown. But the head would not move an inch :face_with_spiral_eyes:. No error messages in the UI and none in the console log (when run from a terminal).

Luckily I found this older topic on an atomstack model: How to: Lightburn on Linux Manjaro, USB, Atomstack X7 PRO, which did the final steps:

  • The vendor id and product id are exactly the same.
  • Driver was already loaded and ttyUSB0 also showed up
  • I ran sudo usermod -G uucp,tty -a $USER and logged out and back in. => no success
  • I created the modprobe config with options usbserial vendor=0x1a86 product=0x7523 and rebooted and it finally worked! Thank you, @rbgo :heart:, you are a life saver!

I’m not sure why the laser did not show up initially and why it started appearing after using the app once and windows 7 once. Maybe they didn’t have anything to do with it and I just had to reboot a couple of times?

Anyway, hope this helps the next guy, who might be wondering if the Ikier K1 Pro works on Linux :penguin: (or at all, :joy:).

Had issues with an Ikier K1 36 and foud the attached USB-cable defective. One orientation works, the other one doesn´t. Difficult fo find

I don’t think that was it, as I tried different cables, all of them USB-A. Though maybe the USB-C Port on the laser itself :thinking:

That was what I meant. Turning the cable plug on the USB-C of the Ikier does the trick. But in my case it was the cable for sure, not the port. Test with another cable was positive in both directions. Cable is in two half and scrapped now.

I like the cut of your jib. :slightly_smiling_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.