iKier K1 Ultra 36W does not connect

Hey there,
I hope you can help me out. My laser seems not to connect (never did). LB keeps saying “disconnected” / “waiting for connection”. Even in the Device Manager nothing happens, when I connect the laser to the laptop - just nothing.

Meanwhile I tried everything - I guess:

  • twisted USB-C Cable 180°
  • Tried another cable
  • Tried all other USB-C ports on my Dell XPS 9510 / Windows 11 (64bit)
  • Reinstalled LB with all possible drivers it offered in installation process
  • USB energy saving disabled
  • Turn on/off…
  • I added manually the laser as GRBL/USB-Port (“search laser” delivers no result")

Any idea? I’m completely frustrated by now…

Thank you! :cry:

Most of the time these issues are driver related. If your OS cannot see the device, Lightburn cannot connect to it.

Check your device manager for an entry for the laser. You can remove the laser, check the device manager usb, then plug it in and check for a change in the usb devices…


Dino, as a last resort you first should create a restore point on your Dell. Then open device manager, navigate to the USB entry, open it and DELETE all entries in the USB section, reboot the computer, go back into Device Manager, and see what devices have been added. Make sure your laser is on and plugged into the USB port.

1 Like

Hmm… I just started using a new Ikier K1 Pro this week. Dell Inspiron i7, Win 10. Connected via USB-A. Plugged it in, clicked find device, done. Other than me struggling with learning the new-to-me LB software, it’s been rock solid. Connects instantly after a reboot/power cycle, and hasn’t disconnected (tho I haven’t yet run any jobs longer than hour or so.).

It registered itself as GRBL-LPC.
I did ZERO driver installation.
I updated firmware to 1.433 before ever connecting to computer. (The firmware does NOT support the extension kit and Ikier support hasn’t been able to help with that, but I got it working correctly in LB anyway with manual changes.

I had to change a couple $ items to match LB suggested config and the extension kit I added, but even before that, it connected and functioned.

1 Like

This may be the key difference.

Note that the correct device type is likely “GRBL” rather than GRBL-LPC or any other variant. I suggest you change this by clicking Devices button in Laser window, then click the name of your laser, then Edit. Then change the profile there and accept current settings for the other choices.

Hmm… I did a quick Googling for the difference between GRBL & GRBL-LPC and it seemed LPC was for 32 bit controllers.

I’ll set up a new device using regular GRBL and see if it has any effect.

GRBL-LPC is for a specific implementation of GRBL onto NXP branded LPC chips. These chips are fairly popular for Smoothieware based boards but exist in GRBL form as well. The implementation is mostly compatible with the “GRBL” device type so isn’t much of a problem at least for the moment. Find my Laser for some reason often chooses GRBL-LPC as a false positive. The bigger risk is that as the implementations diverge further that some people will be on the wrong profile and either run into odd issues or miss out on future upgrades.

1 Like

Good info! Thank you. I’ll be sure to change it.

Thank you Jack, unfortunately nothing happens when pulling the cable out and plugging it again in. There is also no Laser entry in the device manager. Just nothing happens…

Interesting… Maybe a firmware update could be the solution… Where did you get the firmware from?
I connected the laser usb-c to usb-c. I dont have an usb-a…


Only easy way I’ve found to get to this is to use the QR code in the printed manual. I know it looks sketchy, but it’s legit. Ikier support sent me the same link after some back and forth over extension kit setup. Nothing here for that kit, but that’s another story.

Scroll down a ways and you’ll see a link for firmware. Click that, and the next page is in Chinese. I had Google translate it. Not much on that page is clickable. Download and you get a zip file of the firmware. Unzip and put the two bin files on root of a thumb drive (with no other bin files). Turn off laser. Insert thumb drive, turn on laser. It should install automatically.

Per Ikier support, as of Aug 21st, 1.433 is the latest firmware.

1 Like

Probably not a solution, but who knows… We use compact Dell machines with only C ports at work for our older CMM arms, which require USB-A. So we use breakout boxes from Startech to convert. I don’t remember having to install drivers for them, tho. Pretty sure they were plug-n-play, but it ~might~ help you. They’re cheap enough. Clunky as hell, tho.

Wonderful. Thank you!

This is exactly what I finally did… and it worked! Thank you! :slight_smile: :slight_smile: :slight_smile:

When LB recognized the Laser the first time automatically, it was GRBL-LPC. I changed it then to GRBL only. Thank you!

What was your fix? The firmware? Or a USB-C to A dongle/breakout?
Nevermind. I see you marked the device manager cleanup as the solution. Good. Thanks for marking the solution! Always helps if/when somebody else searches for a similar issue in the future.

1 Like

Yes, exactly, I deleted all USB-Manager related devices. Restart and fixed.
I already had the current firmware. USB-C to A was not necessary.
Thank you all for your support!
Have a great day :slight_smile:

Good to hear. Should the day ever come when I need to use C-to-C I can be certain it will work.

I have to correct my last post: for some reason C-to-C did not work than this single time. Did I mix something up in my mind and I always used A-to-C? I don’t know. But A-to-C is now the only thing that works.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.