Illustrator 2020 Possibly Problematic

The latest Adobe Illustrator Creative Cloud update saves the file in a new format. Before I could import an .ai file directly into Lightburn now I have to save as .svg. Not a big deal just bringing it to your attention.

Thanks

Mine just finished updating to the 2020 but I haven’t tried it yet. Thanks for the heads up!

We would love to see that new file format if you are willing to share. :slight_smile: If so, please send to developer at lightburnsoftware dot com and reference this post so we can have a peek.

Well actually I just tried it and it imports just fine and an .ai file.

1 Like

I sent the email

1 Like

That’s weird I tried on a dozen different files and the new ones didn’t open but my old .ai files did. Lightburn software crashed when I tried. I’m also on a Mac if that makes a difference?

The only thing I did was uncheck the box that says “Use Compression” not sure if thats what made the difference but LB imported the file saved as a 2020 version.

1 Like

Did you get a crash report? Which OS version? LightBurn should not crash. We would like to review any reports given when you encounter a crash.

I emailed the crash report

1 Like

I’ve figured out how to detect the new format at least. If files are saved the usual way, with PDF preview content enabled, it falls back to importing the PDF content and works. I have some ideas from the file contents what they’re using for compression, so I might try to support the native AI data again before long.

You’re a genius thanks!

Did you try to do it like I did it? Un-check the box that says use compression when you first save the file.

Yes when I uncheck compression it works fine so it has to do with that somehow

1 Like

Cool, at least for now it works till the LB team gets a chance to look at it.

1 Like

Modern AI files are PDF files with an AI embedded inside in a payload chunk, and LightBurn looks for, and loads that payload, if it can. In AI 2020, that payload chunk now has a comment preceding it that says “AI24_ZStandard_Data”. “ZStandard” is a new compression format developed by Facebook for speed, so I suspect the payload is just compressed in this format. I know where to find code that does it, but it’ll take time to add.

In the meantime, you can turn off the compression to make the files work, or export to an older AI format. When the next release of LightBurn is released, it will see that comment tag and stop trying to read the embedded AI data, which causes it to fall back to the PDF format instead, and it looks like it all just works.

5 Likes

hi guys
is there a fix for this issue as yet?

Yes, and I’m hoping to release within a week or so.

For the moment, save your files with compression turned off, or save in a legacy format.

1 Like

I was unaware of this Forum. I also had AI 2020 update yesterday and it caused lightburn to crash every time. I will try to use the fix listed above, thanks for the info.