Illustrator to SVG telling it to fill shapes and hide lines

I’ve had consistent success with outlines I print (cutting things out) by going from illustrator to SVG

but the current job involves fills and shapes covering lines

here’s a closeup:

How do I tell Illustrator to tell Lightburn to fill that box?

And how do I get the SVG to “know” that a line is covered by a shape so it doesn’t burn that line all the way, but stops when it’s “under” a shape?

I can know I can do it as a PNG, but that takes a very long time and doesn’t give me as much control.

Sorry if this is obvious, but my searches led to nothing.


hello @sethgodin

how do I get the SVG to “know” that a line is covered by a shape

the short answer is, you can not. It is not really a shape, the way its been drawn, its there as a logical path, under the fill in your SVG.

(In LightBurn) You’d either need to delete that section using the node tools, or change its colour to something different and mark that as a layer to ignore in the cuts/layers window.

You might find the documentation on node editing helpful.

I hope this helps.


I’m probably going to work on building more complex shapes in illustrator then, so I don’t have to do a node edit with every revision

thanks for the quick response

Hi @Dominic

thanks for the link to node editing. The “T” command is sort of magical

I got it to work for simple paths

But when I got to my desired image, you can see that they’re both paths, but the T is doing nothing, neither is B.

I’m sure I’m missing something, and advice is welcome!

In short, I have a curved “rectangle” in front of two paths created in illustrator

but it won’t budge.


1 Like

Yes, I agree with @RalphU having a look at the file would help. Alternatively you can send it to support.

support at

thank you both

5 dairy box.lbrn2 (372.1 KB)
3 dairy box

thanks for this…

(If I was writing a novel, Mad Cow Diary would be a great title!)

can you let me know what you did–in general–so I can get smarter about this?

My boss laser is, as of this morning, not working, Y axis won’t move, but it’s unrelated.

thank you

Interesting, I had a look at your file out of curiosity, and did not have too much trouble getting the result I presume you were after in LightBurn by using the boolean weld (The new Ctrl+B boolean assistant is useful here);

I also noticed the issue you had with the trim tool (I will raise a ticket for this in our support system),in the meantime, if you have this issue again, I have found it is possible to “help” the trim tool find elusive intersections by using the line tool to draw a temporary line with corners/vertices placed at the intersections you want the trim tool to find. eg see the red line (I have zig-zagged the line just for emphasis);


As for your Y axis, check your “Enable rotary” is turned off, or if there is a physical switch somewhere that it hasn’t been bumped on.


wow, thank you!

will go dig in

appreciate this.


Hold the phone!, when I went to retest the Edit Nodes “T” trim on the “3 dairy” I had trouble reproducing the problem I thought I had, and I think it’s because I did not fully ungroup all the involved paths (there were groups within a group) and looking at one of your screenshots above @sethgodin I think this was causing you issues also. Anyway, I think I’ll leave my note about using the line tool as it has helped me in the past with other weird trim situations.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.