IMAC - Lighburn - Omtech

I am at a loss. My Omtech 130w worked fine a few days ago. What changed? My iMac was updated and so was LightBurn. Now, I can’t get my laser and LightBurn to talk to each other. It won’t even recognize my laser. I have tried ethernet cables, usb, new cables, connecting directly into the machine by passing the outside plugs. Uninstalling Lightburn and then reinstalling etc. Any suggestions?

How were you connected and working previously? USB direct, through a hub, Ethernet?

Does your iMac have proper USB ports or do you need a dongle? I understand that Macs have issue with the USB connection sometimes, particularly if using a dongle or if it’s USB 3.

Is it possible to connect your laser to a network switch or hub? That’s how I’m connected to my Omtech.

Use Ethernet via your local lan. It will eliminate any USB issue and will likely connect and work.

A bug in Ethernet will effect everyone, not so with USB… If you know networking, you can plug it directly into the PC, but you’ll have to modify networking setup/information to allow it to talk. Suggest you just plug it into your local lan.

You will likely need to change the Ruida IP address to exist on your lans domain.

:smile_cat: