Image engraving dark lines for the first few mm

When i engrave any image. im getting dark lines for the first few mm.
using a K40 with a mini gerbil board.
220mm second, 20percent max
overscan enabled.

Any idea?

Update after installing the latest version it wouldn’t connect to my k40 reliably and would drop connection when clicking stop

After uninstalling and installing an older version from February it connects fine. It seems as though the error noted above might be gone also

Seems that the error is not completely gone. I still get some random times where it will slow down for the first 2 or 3mm of image engraving.

Check your belts and couplings on the Y axis to make sure they’re tight. If it’s slow for the first few lines, it’s likely because it just changed direction and it’s taking up slack in the mechanical system (slop or backlash).

Definitely a lightburn error. Nothing in the belts. Doesn’t happen with laserweb. A restart of the PC seems to have rectified the issue but we will see

This is the laser scanning a rectangle. No issues with the fast scan from the beginning

and this is the laser scanning an image. you can see it slows down for the first few lines and creates dark lines.

Using mini Gerbil board on a k40.

seems to be an intermittent error. After restoring default settings on the cut settings, and turning off overscan, it seems to be getting a fairly nice dither. at the moment. Ill keep testing.

Are you trying to run 500mm/sec with a Gerbil board? That’s likely why it’s slowing down - the controller won’t be able to process GCode that quickly. I don’t know what the limit is for a Gerbil, but GRBL-LPC is my baseline for speed with GCode systems, and that caps out around 2500 GCode instructions per second. You’re trying to hit 5000, and if it can’t keep up, it’ll run slower. Try reducing the speed, 50 at a time, until it doesn’t stall any more.

Yeah, its more for testing right now. but seems as though theres a bottleneck. It was still having issues at 250 and even 50. Right now i cant pinpoint the exact problem. But a reset of the settings, and turning off overscan (which i found i dont need to enable as grbl is handling that task) has rectified the issue somewhat. The image i have is not the best either, using a more uniform greyscale image shows better results.
Im currently going 250 with this image with no issues, except for the sides which still show a very small amount of overburn. Is this a limitation in hardware speed that is causing this overburn?, Should i still enable overscan?

I’m more or less trying to find limits and get the fastest possible speed without sacrificing quality.

Even with variable power you’ll still get edge burn without a little overscan. The DSP controllers don’t let you turn it off. :slight_smile:

Im posting another video. This one shows the issue more in depth.
Greyscale rastering, slower speed, but still pausing at the first bit. then speeds up correctly.

what do you think it might be.

I’m not sure - it could be buffering, but I haven’t seen that before. When I added the new Smoothie cluster stuff I had to add a small delay to the GCode to allow the board time to buffer some commands. It’s possible that the Gerbil has the same issue. Try this: Save GCode, Open the file in a text editor and add the command G4 P1000 to the beginning, then use the “Run GCode” button to run the file. That will add a 1 second pause at the beginning.

trying a new USB cable. So far so good. but ive seen improvements before and then it does this again. Ill keep you informed.

probably wouldn’t hurt to add the delay anyway. Is that possible.

I edited my response above - try that to see if it helps.

will do if it starts pausing again. Ill update this post shortly

nope. started doing it again on the second try with the new usb cable.
Also added the delay, and it does it still. Its got me stumped.

This is the first few lines of code.
Does that Feedrate look off to you?

; LightBurn 0.8.07
; GRBL-M3 (1.1e or earlier) device profile, absolute coords
G00 G17 G40 G21 G54
; Image @ 180 mm/sec, 20% power

Nope. nevermind. Just realised theres no gaps. the feedrate is 10800
well im stumped then

10800 / 60 is 180mm/sec, so that’s correct.