Image flipped in 'Adjust Image' dialogue

Unless I’m missing something this looks like a bug:

My workflow was:

  1. Open clipart in CorelDRAW

  2. Convert to greyscale bitmap

  3. Use Corel/LightBurn macro to bring it over to LB

  4. Adjust Image

LB file attached.
Image flipped in ‘Adjust Image’ dialogue.lbrn2 (154.6 KB)

Not sure if it’s a bug or not but I do know that it’s always worked this way.

Basically, LightBurn will show the image at left in the orientation that it was originally imported in, not in the orientation that it’s currently oriented. The image at right should reflect the current orientation.

Did you need to reorient the image when first imported? Or did you possibly change devices to one with a different origin at some point while designing this?

I’ve never seen this happen before. Admittedly I haven’t done very much with bitmaps in LB but this is the first time I’ve seen it do anything like this

I didn’t perform any reorientation on the image, it’s exactly as it came in from Corel via the macro.

I only have one device, so no switching of origins etc. The workflow I posted is exactly what I did, nothing more, nothing less.

Here it is in Corel:

If instead of using the macro, if you import the bitmap into LightBurn what is the behavior?

If I export as PNG then import in LB it looks as it should in the ‘Adjust Image’ dialogue (ie. the right way up).

I know that the Corel macro uses .AI as an intermediary format so perhaps the issue is something to do with that. However it’s the right way up in the workspace, it’s only in the dialogue that it gets flipped.

Yeah. Likely something in the macro itself or something in the way the .AI file is generated.

Yeah. That’s what I’ve seen in the past. The left image always retaining its original orientation irrespective of other transformations.

This will change based on machine origin setting. For example, my default device is origin top-right and the image shows right-side up. It may also just be that the macro was created with the assumption of top-right origin.

Just reviewed the image again on my top-right machine. While the image is right side up it’s mirrored left to right. So depending on how the image is actually supposed to be, the macro may assume top-left origin.

I can’t see any reference to any specific origin in the macro so I don’t know. I don’t think we (as users) will get to the bottom of it. It needs a developer to look through the LB code to see what’s going on. It’s not a biggy but it’s obviously not right the way it is. Perhaps one of the LB developers will pick it up and give us a definitive answer and hopefully a fix.

I have deleted my last entry because I wrote that it is a bug, after I have also experienced this “phenomenon”. But I can’t reproduce the error, so I can’t claim that it’s an LB bug either.

It’s fairly easy to reproduce:

  1. Import image
  2. Change Origin

The image on left will change orientation.

I just don’t know if it’s considered a bug or not as it’s always worked this way for me.

That is correct, but the 2 cases I have had were without “provocation”.
I just tried again and can confirm what you write. :+1:

A side-effect of the flipped view is that when you zoom in on an area, the flipped view doesn’t zoom in to the same part of the image.

Zoomed in:

Even just rotating within your design will cause the issue. Did you possibly do that?

My normal workflow is import picture, select it, right mouse button-edit picture.
However, I don’t want to put my hand in the fire for not having rotated the two images, I sometimes make many images in a single day.
I would prefer to be as precise as possible in these kinds of statements because I am well aware that misinformation is counter-effective in the troubleshooting process.
I will keep my eyes extra open and report back if I observe it again.

1 Like

It’s a known issue, but it’s also going to be a pain in the backside to fix, as the math gets ugly.

For most people using this tool, they’re importing an image as a bitmap in the correct orientation and just adjusting size and other properties, not rotating it to odd orientations or scaling it strangely.

So, it does occasionally come up, but it’s rarely a show stopper when using it. It’s one of those things where at some point it’s going to bug me enough that I’ll work through it and fix it, but there are bigger bugs to squash for the moment.

1 Like

As I said: it’s not a biggy. It’s never happened to me before so I thought I’d report it. BTW, no rotating or funny business, just a straight import from CorelDRAW via the macro.

As I said, I have only seen it twice and was so surprised that I thought I had hit the wrong key. Nothing is broken or lost, so the world just keeps on spinning.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.