Image Masking issue

Hi, I have been trying to use the image masking for a design I am working on… However its not working like I want it to work for some reason??

Ok… I have my design in the background… Its been all grouped together…
What I am wanting to do is make like a badge to add infront of the design in the background…
So I will upload 2 screenshots… The first one just shows where I used the tool layer to try to make a mask over the bottom part of the image in the center… The second one shows the little badge I am trying to create to go OVER the bottom part of the image in the center…
I want it to be a white background or wood colored with a line around it and engraved lettering in the middle… If that makes sense??
When I select the tool layer then move it over the design, then select them both and try to select apply mask to image, its greyed out and I cant select it???
What am I doing wrong here and how can I accomplish what I am wanting to do??
Any help would be GREATLY appreciated?

OK, a bit hard to fully understand what your final desired output would look like, maybe share an example, but let’s get you on the right track first.

The following is the documentation and a video link showing how the masking options work in LightBurn: Image Masking / Cropping - LightBurn Software Documentation

If I did understand the concept of what you are wanting to accomplish, here I provide a flow:


Something like that? :slight_smile:

Hi Rick,
Yes EXACTLY like that except the oval area will be a bit higher up on my graphic… However I am following EXACTLY the steps you show in the images… I make my oval with the tool layer T1… Then move it over where I want it on my graphic… Then use ctrl A to select all… Then I have tried both ways… I tried right clicking and then (apply mask to image) isnt listed in my choices… So instead I go up on the top menu and click on tools and in the list (apply mask to image) is greyed out so I am not able to click on it?
If you look closely you can see the oval I made using T1 right in the bottom of the picture in the middle of the whole graphic… See I used mask when I added the picture in the middle of this… So thats why im not sure what im doing wrong here?? It worked when I took the circle picture of a bigger picture and added it to the center of this sheild as I call it…
I hope you understand and can see what im talking about…

I should have been a bit clearer on the use of Select All and the layers shown. I believe it is because Ctrl-A - Select All is picking up your Line Layer as well. You just want the grouped Tools Layer shapes and the Image, then right-click. The masking works by selecting a single shape or a single group of shapes (becoming one object) and one Image only. Doing this, you should see the option presented in both the menu and the right-click context menu.

You can use the Ctrl-A if you have the Line layer turned off to not show (red).

Ok well thats actually 2 different images… One for the outside area and one for the circle picture I cut out of another picture and added it to this one… So I need to have it all ungrouped?? Is that what you mean?

You should be working with a single image when using the masking features within LightBurn. One image and one set of shapes as the mask. The “set of shapes” can be any shape or group of shapes (think text as in the example in our documentation), but they need to be grouped as a single object. :slight_smile:

You can apply a mask to more than one image in your project as shown below, but the process of masking requires that you are working with a single image at a time.

Ok… Well this time I removed the outline that was in red from around the whole thing… It is the line that would have cut it out once done engraving… So I removed it from around the whole graphic, Just moved it off to the right… Then I turned off its output totally for that outline… Then I took my T1 oval and put it on the image again… Then hit ctrl A… Then right clicked and here is what I get… Same thing… I also tried grouping everything in the image itself first… Still same thing… Then I tried it by ungrouping the image… Still same thing… Do I need to get rid of the outline totally?? Not just move it and turn off the output?
This is making me feel like im an idiot missing something simple but I dont know what?? Cause ive tried everything I can think of other than removing that outline totally?? Because everything in the main image is grouped together… Well I tried it both ways just to see… It didnt make any difference grouped or not grouped??

Ok… I tried this… I removed both the outline totally… and the outside part of the graphic and I only left the actual circle picture… Now I am able to use the mask… However… I need the oval to be WHITE… so that its not being engraved?? Its doing the opposite… Its just cutting out part of the picture itself?? OMG… I feel so dumb right now… lol… I normally dont have this much trouble doing things in lightburn… Im about to just say the heck with it and leave off the oval with the words on it… lol… Its gonna look good with or without it…

The 2 shapes on that tools layer, the rectangle and the oval, should be grouped. Select that and the image and then do the mask. It is fine, I may be making this more confusing. :slight_smile:

So I bring my oval to where I want it… Then I push ctrl A to select it all… Then I select group… Then when I right click (apply mask to image) is gone… I am doing exactly what your telling me to do… At least im pretty sure I am… its just not working on mine?

Post your file and I can take a look at what you have going here. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.