Image shifts randomly at any speed on XTool D1

Hi there, I have a new D1 10w and have had issues with multiple images and the laser randomly shifting on the X axis.

Here’s some examples:

I’ve had this issue randomly on plain text, simple geometric shapes, and complex art like this. I’ve tried at 100mm/sec, 50mm/sec, and 35mm/sec. Firmware is the latest version, I’m connected via USB-C to USB-B cable with no adapter, and the belt tension is tight but not stretched though I’ve also tried loosening and tightening. This thing is really getting on my nerves at this point. Any ideas?

I notice it seems to be doing it at the same Y lines but to random amounts on X. Could it be some kind of buffering issue?

don’t think so, maybe a mechanical problem, check for belts and for pulley on the motor shaft.

Thanks, what do you mean “for pulley on the motor shaft”?

The belts are moved by motors that have pulley with tooth, check that pulley

It may be worth your time to check the small set screws that secure the pulley to the motor.

1 Like