Import illustrator file with symbols gives dublicate lines

I create my files in illustrator.

most of the times I a symbol of my items.
(So when you place many of the same items on you canvas and you need to adjust something in that item, you do it in the symbol and, tada, ever item on you canvas is also changed. works perfect)

When I import a file like that in Lightburn, those duplicates of the symbol are imported twice, two time on top of each other.

Is there something to avoid this?

Also somthing else, Hidden layer in illustrator are also imported.
Is it maybe a idea to turn this of?

I am working with illustrator CC (2017)
Lightburn 0.9.11

If you can send me one of the files you’re having issues with, I can have a look. Someone else here on the forum sent a file that produces the issue, but their shapes had both stroke and fill on them, so AI files store the curves twice. It’s possible that you are doing the same, so that’s worth checking first.

of course

Here are the files.
In the AI there are two rectangles, both create from the same symbol.
And in the LBRN I imported the AI, there are the two same rectangles. they are imported twice above each other ( on the same location, so you need to drag the one on top to see the other one)

If you need more, let me know.

It’s quite possible that this issue has been fixed, as my current version only imports two rectangles from this file.

ok, great.
in which version is that?
Can I already try this?
Do you have a link to this version?

0.9.12, soon to be released.

oooh great, this works.
No duplicates when I import into lightburn.
And the symbols stay in the a3 file :grinning:

@LightBurn Is it posible to ingore the hidden layers from illustrator?
In this files I have 1 hidden and one normal layer in illustrator.
When I import them to lightburn, both layers are imported and shown.
I would expect that the hidden layers are not imported.

Are you certain of this? I only see one layer in this file, called “Layer 1”

The layer count is embedded in the header and backs me up: %AI5_NumLayers: 1

Whoops, forgot too make that layer.object hidden.

Upload the correct file in that link.
now with two layers (layer1 & layer2)
layer1 = not nidden
layer2 = hidden

but you can also hide groups/objects in a not hidden layer and hide a group.
That is in layer3, there are 2 groups, 1 hidden, 1 not hidden.
both are imported in lightburn.


aaah this problem is solved when you same it as illustrator 3 format.
Thanks @RalphU
From now on illustrator 3 is my new favorite file format :smiley:

LightBurn currently ignores disabled layers, but not hidden ones. I’m adding a flag to allow you to choose. I can’t find the hidden property for the grouped object though. Can you do this:

Make the same file, but use four rectangles with different colors:

  • Red is not hidden
  • Green is hidden in the layer
  • Blue is hidden by object

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.