Importing a DXf file is too large

When I Import a DXF file it import the file but HUGE. like 409 X 399 or larger. I half to Ctrl a then shrink it down to say 10 inches. I Am I doing something wrong or a setting I need to adjust? Please help. This is getting tiresome.

Like 25x larger? try switching Lightburn to mm and see if that makes a difference.

Or it may be the drawing is just plain huge.

If you are designing your DXF file in inches, make sure you have the DXF import settings set to inches. You get to that screen by Edit>Settings and click the File Settings button.

I have it set to inches, and its huge.

I’ve tried mm, still imports huge

Can you upload the DXF file here?

If the Auto-detect units if possible switch is turned on, LightBurn may be automatically detecting the wrong units. A while ago, somebody had a file with units in microns that insisted it was really scaled in something else. Hilarity ensued.

Flip that switch Off and see if the import makes more sense. You must also pick the proper units for the file, but it should at least be possible to get a reasonable file size.

Thank you I will try that.

A yawn is a silent scream for coffee.dxf (476.6 KB)

Tried…no sucess


my settings

760.9986 x 780.0000 way too big the file is only 477 kb

Importing into corel draw, it is that big!

image

Is there a way to bring it down before import? Or am I stuck doing it manually afterwards?

You need to use a smaller unit if you want it coming in smaller. So with auto-detect disabled, select mm, then import.

Without knowing the actual expected size it’s hard to say what the proper units should be.

Will try. Thanx

Looking through the DXF file in a text editor it is configured in Inches:

image

The ‘1’ denotes Inches. If this is changed to ‘4’ (denoting mm) it comes in 25.4x smaller (as might be expected).

To quote @Bikemike :

I’ve tested both the original and my edited version (with the ‘1’ changed to a ‘4’) in LightBurn, CorelDraw 2018, Affinity Designer and Inkscape. All applications observed the $INSUNITS setting except for Inkscape.

Anyway, hopefully that will clear up any confusion regarding the sizing when importing this file into LB. The graphic really is this big and LB is reading it correctly. The easiest way to get it to your desired size is to do as you have been doing and scale it in LB, after all it’s not difficult or particularly time consuming.

Hope this helps.

I had this problem and cured it by converting the file to .plt file This then imports into Lightburn at the correct size
I am using SerifDraw X8. There must be other drawing programs that are capable
Hope this helps

CorelDraw will also export to HPGL .plt format.

Way back in the early 1990’s when I was a CNC programmer/setter I wrote a program in VB3 (it started as a command-line program called PLT2CNC that I wrote in Borland C) for doing engraving on CNCs. I would do the design in CorelDraw then export it as a .plt file. I used this format as it contained the ‘pen up’ and ‘pen down’ commands which made it easy to transcribe into Z moves and trigger spindle/off on etc. It had the capability to map a design (X or Y axis) to a 4th (rotary) axis and also to a spherical surface. As long as the z-height of the surface wasn’t too deep it worked quite well (the further round the sphere you got the more error you get due to the cutter not being perpendicular to the surface).

I tried to sell the software to Gravograph but they weren’t interested (they didn’t even seem to be aware of CNC at the time!).

Anyway, in the OP’s case LB isn’t getting it wrong, it’s opening it at the correct size.