Importing Designs from Carbide Create

I posted this in the Carbide Create forum as well…hoping for an answer from someone who’s done this before:

I create a design for some parts in Carbide Create for my Shapeoko router. I want to use the CNC to create the pieces, cut them out, etc. Then, I’d like to etch specific details into the piece and need to design those in LightBurn.

Is there a way to export a file from Carbide Create and import those into LightBurn in such a way as to allow accurate sizes and positioning of the design elements, so that I can add additional elements in LightBurn…and be certain that, as long as I register the starting point accurately, the burns will be in the right places?

Thanks in advance,

  • Gary

What formats can Carbide export in? Or, alternately, if you imported data into Carbide from an SVG, AI,or DXF file, you can import the same file into LightBurn and the scale will be the same.

they post a broken svg. their export to svg is terrible.

I exported an SVG in CC of two boxes, one 3x3, the other 4x4. When importing the SVG into LightBurn, they measured 4x4 and 5.3x5.3 respectively.

I’ll have to continue to explore this…but this does not “just work”

Interestingly, it seems that the image in CC is exactly 75% of the size in LightBurn in all cases (that I’ve run so far). Down to the thousandths of an inch. However, the files do not start in the same place in the designers (in CC it’s at 0,0 and in LightBurn it’s somewhere centered on the page. I don’t know if that will always be the case, or if it will be the same for everyone’s setups, but it’s good enough for me for now. All I need to do now is put a reference point on my objects so I can easily set up the origin.

Any ideas?

1 Like

That supports my 75% observation!

When importing, LightBurn always places art at the center of the view, or if you drag & drop, at the cursor location. SVG files use a top-left origin, so placing them exactly where the file specifies will most likely put them off the page. You can make LightBurn do this by holding the Shift key when you import.


So I’m coming from the Carbide3D forum where Gary and I had this discussion, I dug a little deeper and I did the following test: I created a 100mm straight line segment in Carbide Create, exported it to SVG, and imported it in LightBurn, which as @GJM reported resulted in a 133mm line.
Out of curiosity I also created&exported the same 100mm line in LightBurn, and in Inkscape, and tried to import each sample in the other two software, and observed this:

Taking a peek inside the exported SVG files from each software, I saw this (heavily edited for clarity)

SVG exported from LB:

<svg width="100.000mm" height="0.000mm">
    <path d="M15.000000,49.000000L135.000000,49.000000"/>

SVG exported from IS:

<svg height="297mm"  width="210mm">
    <path d="M 0,0 H 100"/>

SVG exported from CC:

<svg width="377.953px" height="0px">
	<path d="M0 0 L377.953 0 "/>

So I don’t really want to discuss how broken or non-standard Carbide Create’s SVG export is, my point is that it seems to me that CC does use 96DPI for export (100mm at 96DPI is 378px), and it’s ONLY when the imported SVG has the unit in pixels that this 133% scaling effect occurs, which fto me looks as if LightBurn somehow uses 96DPI when the SVG values are (properly) specified in mm, but interprets values in pixel units using a 72DPI reference ?

I may be completely wrong of course, and I am SVG-illiterate, so this is just to try and understand LightBurn’s import behavior and whether this is intentional.


And Inkscape imports the CC export “correctly”. I’m thinking, this is just a matter of what LightBurn (and Illustrator apparently) defaults to when the unit is px, which (unless my test is broken) is probably 72dpi. CC shouldn’t use px in the first place, this is really just to double-check my assumption.

‘px’ is pixels - it is not a standard, though css does define it as 96 pixels/inch, and LightBurn is using 72. I can change this, but it’ll probably break something else, like Affinity Designer, which also fails to use “real” units.

@LightBurn Could you give us an option in the settings: SVG Import Resolution: (96/72)?

I’ve changed it to use 96, as it does seem that InkScape and css agree on that. If it becomes necessary, I can add a setting, but it’s kind of crap. The whole reason to use measurements instead of pixels is so this kind of thing doesn’t happen.

1 Like

Yeah, but you’re not the culprit, you’re the victim.

1 Like

@LightBurn: thank you! (and sorry to have exposed you to CC’s unorthodox and undesirable px unit for SVG export, and to SVG implementations discrepancies in general…this is no fun)

How do I get access to the new version?

You download it when it is released.

@LightBurn Ah…that’s an interesting concept. I do get it. It’s called “Patience”…I think. I’m just not all that familiar with it.

That, and reading, seem to be completely alien concepts to many people we interact with.

@raykholo And also reading.

@LightBurn Am I correct that this fix did NOT get into 9.13? It is not fixed as far as I can tell. I still need to size incoming designs by 75%. Is that what was intended?