Importing settings

Is it possible to set your importing settings so that designs import to lightburn ungrouped?

Not at the moment, no. They’re imported that way to make it easier to grab a single design if you import multiple items together.

1 Like

I have added settings to the next release to let users choose:

  • grouped imports enabled or not
  • imported files auto-selected or not

Oz, if i would like to keep importing as a group - will i be able to select the group on canvas and see the layer in Cut’s window? even only alerting the user that the image is selected but it is a group and we need to ungroup it to be able to edit all associated discrete layers. i believe this behavior is still needed.

If you import an image, you will see “Image” in the cut layer list, so it’s generally quite easy to find, grouped or not. You do not need to ungroup anything to edit the layers associated with shapes, you only need to ungroup to edit the shapes themselves.

Hi Oz and thank you for taking the time to listen to what i have to say. For the sake of my argument, can you tell which one of the primitive shapes and/or butterfly are grouped? only one is not, which means that out of all the shapes that you see on this canvas, when each is clicked on, only ONE will be highlighted in cut’s windows. all the rest will NOT show you anything. so, if one wants to find the layer, it is not enough to select the obvious which is the shape on canvas but to go to the long list of layers and right click each to find out which is which and on my 3K 32" screen you can’t see the type of frame that distinguish whether it is a group or not (doted/dashed/… it’s way to thin to notice), and you wont see any of the associated layer in cuts window.

Just saying. by all means i am not pushing you to the corner. just pointing out a scenario which is more than likely to occur. and… maybe i got it all wrong and I need to turn my head around :slight_smile:

The ability to select the cut layer by clicking the artwork is a convenience, not a requirement. You have two layers with ‘Output’ disabled, which dims them, and that will make it harder to see the selection pattern. You can right-click a layer in the cut list and it will flash the content of that layer to show you what’s using it. You can Shift + click it to automatically ungroup and select the layer content.

You also have “Wireframe - Coarse” rendering enabled, which produces thinner lines than 'Wireframe - Smooth". Switch to ‘Wireframe - Smooth’ and that will make it easier to see the selection pattern too (in the Window menu).

On my 32"/1K pixels screen the selection pattern is very noticeable. Not so on my primary 32"/3K pixels screen.