Incomplete Cuts on PCB

I am attempting to use an OMTech 20W Fiber Laser to etch PCB traces, however the start/end point of each of the paths does not correctly cut leaving a completely electrically connected board.

Attached is a photo showing the issue on a test pattern.

You don’t have tabs on do you?

Also, just out of interest, does the charred FR4 conduct?

There are no tabs in this calibration pattern. The FR4 does not conduct and isolation can be observed if the undesired copper is manually removed.

My bet is on this being related to your Timing - this page in our docs

Your galvos are probably starting to move before the laser source is fully on, leaving these spots. You can adjust your timing manually in the Cut Settings editor by clicking the Show Timings button.

Laser Everything has a great video on the topic going into depth: The COMPLETE Guide to Timing and Delay for Galvo Lasers - YouTube

FR4 doesn’t, but what about burnt FR4?

It’s basically carbon.

@ColinW I will give the timing adjustments a try.

In the documentation for Line Mode I saw that there were Advanced Options to add pause time at the start and end of a cut. I have not seen this advanced tab in either your or my screenshot. Is the documentation outdated for this feature?

Some of the Cut Settings Editor pages will vary laser to laser, and that page was (largely) written before galvos were a supported device. Your screen will look slightly different because that screenshot is for a different machine category.

If you click “Show Timings” you’ll get timings overrides for that layer, including the polygon dwell timing. The explanations for the timing options are explained in the link Colin shared above. Hope this helps! :slight_smile:

The timing adjustment did the trick and the PCB is being etched cleanly!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.