Inconsistent Connectivity Problems

Im using the lightburn bridge, and have been for about 2 months no problems. This past week has been very inconsistent. I had the pi inside of the laser machine. I sshd into the pi and ran iwconfig. My link quality was 44/70 and signal strength was -66dbm.(Doesnt really seem that bad, right?) It would work fine for a couple hours and then it would fall off the network. Not being able to do anything i would pull the sd card out reinstall the OS and it would work great for a couple of hours. Finally thought it was fixed and i went to send a job over and it was off, again. So i removed it from inside of the laser, have it outside and now getting 54/70 link, and -56dbm. I did notice that once it fell off the network the AP service started again and i had to connect to it and re setup the wifi. Is there a reason it isnt connecting automatically? Strange that it has worked great without ANY hiccups but now all of a sudden there are problems… I have reinstalled the OS. Have a monitor plugged in at the laser and can see the network status screen.
Network is connected and showing me the IP.
RUIDA relay started, laser IP
No issues found.
If I turn it off and back on and it’s back to WiFi config AP running.
I can’t seem to access it from my computer. I also cannot see the pi using the “fing” app. Any input would be greatly appreciated. Thanks!

I tried to find an edit button. Heres an update.
I have reinstalled the lightburn bridge software to the pi. I have noticed that if i use the wifi.txt with my login credentials. It will not change it to wifi.txt.failed, OR wifi.txt.loaded. It stays the same. So, I set up the wifi through the Lightburn Bridge AP page. It reset and worked all day yesterday. I shut the shop down and went home for the evening. When I got back to my shop this morning, it wouldnt connect. The AP was not running, indicating it was on the network. I look at all of the devices and can see it connected, but the status page is not working. I then shut the pi down, plugged my monitor into it and turned it back on. It then tells me the AP is running and needs configured. So, again I connect to the Bridge AP, set it up on the network, and it has been taking commands all day no problems. I however am not able to access the status page. Is there something I am missing?