Initial Rotary Set up Issues

iMac with most recent version of Lightburn operating a Ortur Laser 2 Pro 20W and just installed the Ortur YRR rotary. Gone thru all the setups and watched multiple videos to include freeze framing each step to document the set up. When I start a burn the laser traverses all the way across the x axis without stopping and errors out. Unable to test in rotary setup screen. Everything looks right… point me in the right direction…


tutorial covers pretty much everything you need to know to setup the YRR including saving old configuration settings and creating new ones.

One thing I’ll emphasize is that you need to set your laser to use Start from current position after you’ve manually centered the laser on the rotary workpiece. LB and your controller has no idea where your laser is positioned since you can’t ‘home’ it in the usual way.

Appreciate the response. I had already watched your excellent video twice and wrote each step. At one point I receive an alert the Lightburn settings are different from the controller do I want to save the settings to the controller. Each time I have selected no. Should I select yes?

Yes, you should select yes so the changes can take effect.

To clarify, the excellent video is by @richfaraone , I’m merely an advocate of it… :slightly_smiling_face:

1 Like

BUT, be sure to save your original settings in a unique file so that you can easily restore them when you switch back to normal XY mode!!!

Thanks team… I’ll make the changes this evening

Verified all the settings, made a default and rotary set up file. Saved set up to controller. Had success switching back and forth between set ups. Initially received error code 9 “homing error” when I performed the accuracy test. Now I’m getting “waiting on connection” and when I look at the machine settings it is blank with the message “Communication with controller failed”. When I attempt to load the default or rotary files it fails with the same “Communication with controller failed” msg. Thoughts?

Anytime I see that message after messing with settings it usually means that my port settings changed. Check your device port selection.

1 Like

That was the first thing I check, and I did have to change it but didn’t make any difference on the operation

Uninstalled and reinstalled Lightburn. Lightburn homes the laser at start up and seems normal until I perform any function that requires moving the laser. First command results in error code 9. When I re-home the laser I receive a message the laser is busy? Lightburn is addressing the correct port. Any additional thoughts or suggestions???

Yes, Lightburn should NOT be homing the laser when you have the rotary attached. The video clearly shows disabling auto home when you set up the rotary. Perhaps you need to watch the video one more time…

1 Like

I disconnected the rotary when I ran into the issues last night. The issue I outlined earlier today is with everything set up for standard X/Y activity.

Error code 9 was preceded by error code 2, which pointed me in the direction to research homing errors. Found the issue… laser was homing to -397 -397. Another user with a similar homing issues had a suggestion to use $RST=* to restore defaults. That worked for my unit.

1 Like

You can also just right click on the Devices button on the laser tab, and then select your COM port to solve this issue. You may not see it happen, but right clicking on the Devices button performs a reset.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.