Initial setup (limit switches & swap axis for better usability) am I doing it right?

So I recently got a Sculpfun laser engraver and and expander kit (which expands y-axis a lot) Fig. A.
In this configuration I have to turn it 90° to fit on my table Fig B. For better understanding I even drew it all :blush:.

I) Now having the axis rotated by 90° is very odd, so I figured I might be able to swap them?
This should be accomplished by just swapping the connectors on the board and then adjusting the axis direction in the $3 mask, leaving me with Fig. C as a result.
Now swapping $100/$101 & $110/$111 & $120/$121 and putting in the correct axis length at $130/$131 should get rid of all issues, right? Is there anything else I might need to address?

II) I also ordered some limit switches. Installing them in the new top right corner might be the best bet for wiring, since I can combine it with the existing cables Fig. D. Is there a better advised position for those switches?
In theory I just need to enable them ($22) set the directions correctly ($23) and adjusting all those other $20-$27 if any errors occur, is this correct?

III) Now with those limit switches in the top right, it would be a good thing to also set the global home/origin in lightburn to the top right, wouldn’t it? But I’m quite lost on how to do this. Is it just as easy as setting the origin in the device settings in lightburn?
image

Thanks for your time and helping out an absolute beginner :sweat_smile:

Depending on your current setup you may not even need to invert anything with $3 mask. But yes, if these needed to be inverted you would do that there.

Are these settings different today for X and Y? Typically both axes share the same setup. But yes, if these were different then you’d have to change this.

Yes. This is a must.
Did you change the timing belt pitch or pinion size with your mod? If not, then all existing figures should hold. If you did then $100-101 will need to change.

Does your new X-axis have 2 steppers or does it use a drive shaft to drive the belt on the opposite side?

This seems sensible. The main consideration here is that you have proper clearances for the laser head and anything else moving.

You would actually enable the limit switches with $21=1. $22=1 enables the actual homing function which you would want to do. $23 as you say would correct for direction. I suspect you’ll want this at $23=0 once $3 is set correctly.
If soft limits are not already set with $20 I see no good reason not to have it on.
Yes to refining with other settings.

This is referred to as machine origin and yes, you’d want this on upper right. You set this in LB device settings.

One thing that’s missing from here is that depending on how your GRBL firmware was compiled that the new machine origin may be set to either 0,0 or possibly possibly the x,y of your new frame size or something else. If this is set to 0,0 or anything other than the full frame size then that will effectively put your bed into a negative coordinate space which LB does not like. I suspect this will go to 0,0.

In that case you will need to create a work offset.
G10 L2 P1 X-[x length] y-[y length]
$10=0 ;this setting will have your controller report working coordinates vs machine coordinates

If it homes to something else you would need to adjust accordingly.

1 Like

Wouldn’t it be easier to swap the X & Y motor cables and limit switches…?

It will home in a different ‘quadrant’, but that should be easy to deal with.

:crazy_face:

No, everything stayed the same, except for axis length. There were longer belts tho, but same type.

It is a drive shaft, but the gantry did not change at all, only the basic frame.

Ah, is see. So those settings affect each other.

Oh I see, this is the same as referenced here: Common Grbl Setups - LightBurn Software Documentation under “Negative Coordinate Machines” I think I understand it, but still hoping it will just work out. :sweat_smile:

I will report back in a while once all is done.
Thank you for your time :slight_smile:

Sebi

This is exactly what I’m doing: 1. Swapping the motor cables; 2. Ensure directions/settings are still correct with the now swapped axis; 3. Install limit switches in a convenient place and get homing to work; 4. Match up origin with home for best accuracy and to not run in some strange issues.

I’m advising just swap cables, not moving anything.

Let it home, now it will be 90 deg from where it was, but the axes are swapped. You should just have to set the new ‘home’ location in Lightburn…

When you need to change stuff, do it through Lightburns GUI in ‘Edit → Machine Settings’. No figuring bits or dealing with $numbers, all in readable language. Don’t forget to ‘write’ it back to the controller.

Get it functional, then modify more stuff…

:smiley_cat:

There is no homing or limit switches by default, so there is nothing to swap. I purchased them separate from the engraver. So I need to start from scratch and pick spots for the limit switches anyway.
Swapping the axis is not the exciting part, neither is adding limit switches.
The actual difficult part is setting origin to the top right corner and avoid issues (like negative coordinates, which I did miss) while doing so.
The explanation of swapping axis and adding switchen was just to make sure, I m on the right track, and to give some impression, why I am wanting to change the origin and berainlb answered all I needed to know for this :slight_smile:

I did not knew there was a GUI for this, since I hadn’t a chance to connect it yet. But this makes it easier I guess.

Trying to :wink: But planning ahead with issues that might arise is always a good thing.
I still have an air assist down the line, but not bothering with that atm, except for where to place the nozzle and where to run the hose for sufficient clearance, so I don’t have to start over again later, because I misplaced something during my previous mods.

So here I am again.
Cables are switched and y axis needed to be inverted.
So did homing direction for X and Y.
Settings for X and Y were the same except for axis length, which I did correct.
Apparently everything is working just fine with setting origin to the top right.
There are some negative coordinates after homing:


Does that mean I have to do the workspace offset thingy?

Also the limit switches and homing are a little odd to me.
My board has 3 pins for each limit switch (Sig; 5V; GND). I somewhere read to use Active-High configuration so I wired them up like:


Which did work with $21 and triggered an alarm when bumped.
Homing did not due to “ALARM:8
Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring.”
Setting $5=1 did work but the description of $5 says “NOTE: If you invert your limit pins, you will need an external pull-down resistor wired in to all of the limit pins to prevent overloading the pins with current and frying them.”
And since I don’t have a pulldown or any suitable knowledge in electronics I might just ask again what to do?
If I set $5 back to 0 it does still work, when wiring like Active-Low as the description of $5 requests:

But which is this correct and safe way to go without any pulldowns?

Use the pull down or ‘wired or’. It is easy and simple to get used to.

In simple terms, the controller will generally have a ‘pull up’ on that pin as an input. All you need is ground on a mechanical switch. All you need to do is pull it low for active. Then you can disable the $5 stuff.

If you use some kind of ‘hall effect’ switch you may need power also.

This is the Z axis limit.

Good luck

:smiley_cat: