Inkscape > Lightburn Scaling is Off

A super simple acrylic mounting plate that must have precise hole spacing. I use calipers to measure the mating holes and draw it up with Inkscape, in inches, which I’m very used to using. I set the line weight to .001 on the vectors so that all the spacing is very accurate. When I open the 4x4in plate with four mounting holes using Lightburn, it now measures at 3.785. I can’t find a reason for this and would appreciate some help. Here’s a screen shot.

How are you “opening” the file in LB and what file format are you using?
If you copy & paste your square directly from Inkscape to LB do you get the right size?

I just tried drawing a 4" square in Inkscape and saving it as SVG and importing to LB and I got the expected 4" square.
Copy & paste from inkscape to LB worked also.

I would suggest that your SVG import setting is wrong, but your ratio of 4.00 : 3.785 doesn’t really fit that…

Do you have a stroke width applied to that line in InkScape? If so, it might be showing the outer dimensions including the stroke width, instead of showing you the ‘geometric size’ (just the size of the fill) on that shape. That’s about the only thing I can think of.

1 Like

I thought about that also, but that would be pretty creepy if adding the stroke width to the geometric shape resulted in a smaller size…

Weird,I just had a look in Inkscape 1.1 and I can’t even find where to turn use “geometric bounding box” on & off anymore. It seems to have disappeared form the preferences menu.

LOL, yep, there it is, right where it used to be but somehow I just couldn’t find t. :rolleyes:

I think I’m losing my mind. Maybe that’s what the cats were playing with the other day. I caught a glimpse of them batting something kind of small and hairy under the couch…

Hank, I’m using LB to open the file, making sure to select the .svg file type from the folder. I double checked the file settings. I tired cut & paste as well. exact same result. It’s really strange and there seems to be no obvious issue.

Did you check the Geometric bounding box setting? That seems the most plausible cause.

Changed the bounding box settings and still have the exact same issue. This seems like such an obvious fix, that others would have had already. Would the version of Inkscape be in anyway related? I know when it was last update, there was some DPI “fix” that was installed.

That’s so weird. I’ve used Inkscape for over a decade, and with LB for 2 years and never seen that.

So your 4" square came out 0.215" too small. If you draw a larger or smaller square and try it does it still come out 0.215" small or is the discrepancy scaled to fit the object? (Does an 8" square come out 0.430" too small?)

You can attach the SVG here (or email to support@lightburnsoftware.com, including a link to this post for context) and we can have a look at the file itself.