Installed Lightburn 1.5, now my software can't see/find my laser

I loaded the 1.5 lightburn onto my 50W Ruida controlled laser this week, and just today got on the computer to cut a design I’m working on. I’ve had it working fine for 3+ months with no issues before the upgrade. I tried to have Lightburn find my laser, I tried entering it manually. I’ve checked the computer’s USB port and the cord running to the machine. The physical connection is solid.

But when trying to communicate with the software, it’s as if nothing is there.

Help!?!?

Did you reboot the computer? My wife’s did the same thing after updating. Forgot to reboot after the update. That fixed hers.

Yeah, rebooted the computer, even restarted the laser. Its acting like nothing’s even there. The controller works off of the keypad. But that’s it. My Lightburn program may as well be a screensaver right now…

Sounds like the pc has forgot how to use the usb port. I have seen a post about a bug of some sort with usb. Does your engraver have Ethernet? If so I would use that instead of usb. My wife’s kept dropping her usb for the polar, so I only used the usb for the camera. The machine is hooked up Ethernet.

1 Like

2 Things. And I will say I’m in the same place with a 2nd hand laser, so they haven’t worked for me, but I will throw it out there anyways as they seem to be solutions for some.

  1. In the power setting on a PC/laptop, there is a setting to disable the USB to sleep , this should be turned off (disabled).
  2. Did you install the drivers. It’s the top checkbox in the very last screen when installing lightburn (these are for DSP machines only I believe).

Sorry, I’m not much help, I’m as frustrated as you are. It seems like the port isn’t even active on my machine (Chinese 50W). The other port works (I can transfer with a USB stick), just not connect /find the laser.

Good luck, please let us know what works!

1 Like

I’ll try these. I will also pick up an lan cable, and hope that I can still maintain my wifi connection on the computer while using the cable for the laser (I obviously have relied on computers to fix themselves through troubleshooters over the years. never had one that I couldn’t fix it with a reboot or a patch!).

I did not click the box for the DSP when I did the update, like I did when I first loaded the software. Is there some way I can enter it now?

Lightburn calls the OS to connect to a device. Some devices had special handling of the data so they have drivers installed to handle these. The driver is not related to Lightburn, only OS software deals with drivers.

If you can see your laser in the device manager, then the OS can probably see it and Lightburn should find it.

The advantage of Ethernet, is everything talks over the same medium… no specialised software really required. You can’t easily plug it directly into your Ethernet jack, but you can plug it into a switch or router. If you want to plug it into your Ethernet connector directly you’d need some network knowledge to make that happen… I’ve run mine, both over the network and via a direct connection between the pc and the Ruida.

The most easy way is put it on your local lan. For quite a while I ran a $12 t-link wifi bridge on mine.

The Lightburn PI bridge works well and has a software layer to help with the Ruida UDP comunications. I had an extra PI laying around, so just installed the image from Lightburn on it and ran.

If you can, use Ethernet over your lan…

Good luck

:smile_cat:

I ordered an Ethernet cable that will arrive today. I’m a 60 year old who uses a bunch of tech, but I’ve always had the blessings of plug and play to get me by.

That alien language you were speaking right after you said that I can’t just plug my cable into the PC and the LAN port on the laser…

We’re you saying I just need to buy a router? Could you recommend what I need off of Amazon? I don’t want to buy something that ends up being the wrong thing. I just have Lightburn running off a Dell 8300 right now, but would like to put it on my gaming laptop as well, for times when working on designs seems more comfortable from a recliner than my desk chair. Would that affect what I need?

I appreciate the help

If you have access to a switch or the router on your lan, you can plug it in there. Might need to change the Ruida ip address.

For a wifi setup, any wifi bridge or any router that can be configured as a bridge.

As I mentioned, the Lightburn PI bridge does this with a bit of code to handle the Ruida with it’s UDP communications.

:smile_cat:

My router for our home wifi is on the opposite end of the house. I was hoping that I could just plug the ethernet cable from the computer directly to the desktop, which are literally 2 feet apart. It is sounding like this is not going to be an easy fix for this boomer brain… There were only 2 hardwire ports on our internet provider’s router, and we had the upstairs and downstairs TV’s connected to them.

I wish when I installed the update it would have told me I needed to select the DSP or the other option. The window just said it was installed, to select “finish”. Until I can figure out a solution that I can wrap my head around, I’m looking at the world’s largest paperweight.

Let me clarify…

You have used the two Ethernet ports on your router for the two TV’s?
You are using wifi on your pc to access you lan?
Do you have an Ethernet port on your pc?

@berainlb might be able to help you configure windows to use the Ethernet port on your Windows machine. I know how to do it on my Linux machine, the basic idea is the same, but I don’t know how to do it on your machine.

Worse comes to worse, I’ll try and find my old one in the photo and I can arrange to ship it to you, you get to pay the shipping :grimacing:

:smile_cat:

1 Like

Yeah, when the kids were here, we had the PC in the dining room so they could do their homework. When they hit college age they hooked the Xbox One on the living room TV up to the ethernet cord where the PC used to be and we ran the other to the family room TV. After that, they basically did all their homework on Wi-Fi with their laptops. I repurposed the PC to become a dedicated computer for the laseroom (one of the unused bedrooms) when I got into this hobby last spring. It connects to the internet via Wi-Fi, but the connection is spotty this far from the dining room. Our internet provider told us to ditch our linksys Wi-Fi router around 8 years ago, and they ran everything off of their hardware, which I guess is a modem/router built into one(?)

I located the install file for Lightburn 1.40.04 (I believe), and was wondering would it be more sensible to delete the 1.5 version and reinstall my original lightburn? I am totally open to wiring up the laser through it’s LAN port instead if it’s doable just to get rid of the USB cable running out of the front of my computer. I do have a Lightburn camera (that still works) using the other one, but it’s be nice to have a phone hookup there for convenience.

As far as the shipping, that’s cool by me, or if you can’t find it, and can tell me what I should buy, I could go that route.

I appreciate your help

Here are a few from Amazon that should work…

https://www.amazon.com/BrosTrend-600Mbps-Adapter-Wireless-WNA016/dp/B0118SPFCK/

https://www.amazon.com/WiFi-Ethernet-Adapter-Wireless-Bridge/dp/B0CM8RMD7Y/

https://www.amazon.com/TP-Link-Wireless-Portable-Travel-Router/dp/B00TQEX8BO/

This is the one I got that’s in the picture… it’s also the lowest cost… It’s not always available.

https://www.amazon.com/gp/product/B08GS211V9/

Ensure you read the directions before you power it up so you configure it as a wireless bridge.

I am kind of worried about your distance from the wifi source as the first three plug directly into the socket. This goes through the network, not from your machine directly to the bridge…

:smile_cat:

Thanks. I’m going to delete and reinstall my Lightburn version 14.04.yada yada yada today to first see if I can return the communication to the laser, but I do want to try to get it wired via LAN if possible.