Integrate Ortur Lasermaster 2 into Lightburn


I finally wanted to properly integrate my Ortur Lasermaster 2 into Lightburn (Homing / zeroing etc.).
Until now I have always taken the detour via LaserGrbl and used it there.

I’m stuck at the following point.

I start Lightburn and the laser moves to the bottom left and positions itself there.

That fits too

But as soon as I go to the Motion tab to get position, it doesn’t say X0 Y0 but X430 Y400.

So I can no longer move the laser because it thinks that it has already reached its maximum value.

I have no idea where he got the values ​​either.

I have stored the values ​​X400 Y360 everywhere (Lightburn and Lasergrbl).

What am I doing wrong?

There is always an error message (when there is movement) that the maximum working range has been exceeded (unfortunately I can’t remember the exact wording).



I had a similar issue but it was after attempting to use my YRR. I was advised to type $RST=* into the console and hitting enter, which fixed it for me.


it works.
What does the command mean?

Thanks & Greetings

firstly type
press enter in console
press enter
Copy/paste the full output here please?

That’s great, I’m glad it worked.

According to Github:

$RST=* : This clears and restores all of the EEPROM data used by Grbl. This includes $ settings, $# parameters, $N startup lines, and $I build info string.




I would sugest a updaet infirmware as you are very much on 2020 firmware

In console $RST=*
press enter
WHen machine replies with [MSG: restoring defaults]
Tap the reset button to power it off

Donwload unzip and follow PDF instructions

Thanks :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.