Inverted Build/work Area on Atomstack A5 pro

Hello folks. I am new to laser engraving and recently purchased an Atomstack A5 pro. After some trial and error I was able to get it recognized on my Macbook pro (Big Sur).

Before I turn on the atomstack I move the laser to the ‘home’ position in the bottom left corner. (Is this incorrect location for the atomstack ‘home’ position?)

I start LIghtburn.
On the ‘move’ tab I select ‘Set Origin’ and ‘Set Finish Position’, because this is the origin of the print and where I want it to return when it completes.

I see the red target appear in the bottom left of the work area window, this is where it should be. When I manually move the laser it moves in the correct directions. With an image file placed in the center of the work area, with a green square associated with it, I hit ‘start’ and the laser moves in the opposite direction …right into the rails.

I have it set to start from ‘User origin’, not sure if this is the best setting for me. Both ‘Home’ and ‘Go To Origin’ never work. From owning many 3d printers I hypothesize that this is because there are no limit switches to communicate where the laser is precisely located upon start.

Second…Are there any limit switch installation tutorials out there for the atomstack a5 pro (I googled and didnt find anything)

I read somewhere else to move the laser to the desired start position then run:
G92 X0 Y0

then run:
$10=0

but I could be completely incorrect. Please help.

What do you have here?

Thanks for the reply! Yes I have that set to the bottom left selection, however, this isn’t what I am referring to. Everything works fine with movement and print start location, however when I press ‘Start’ the laser does not move from the bottom left corner to the middle of the work area, but rather attempts to move inversely, crashing into the rails.

TBH it sounds like you’re doing everything right. Has it always done this or did you just set this up?

I also unplug the USB cable but otherwise I do exactly as you do.

1 Like

I just got it setup. I think it’s a firmware issue or alternatively somewhere in Lightburn there is an “inverted” XY toggle possibly. I emailed Atomstack…for now I just manually move the laser to the top right and press ‘start’ and it moves to the middle of the work area properly.

1 Like

You might need to set it up again, perhaps you put the wrong co-ordinates in. Anyhow, good luck and welcome to the forum.

Where is ‘Job Origin’ set?

Does your machine not home?

If not, you should go over Common grbl setup.

Screenshot from 2021-10-13 16-38-28

https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

You are probably correct in your deduction that it’s probably configuration :slight_smile:

Welcome aboard.

:smiley_cat:

Job Origin is set to the bottom left selection.

No sir, I can’t get it to home. But it moves when I press any of the arrows.

I’m going to try from my PC and reconfigure it then see if I get different response from the Atomstack.

Good luck on that, I would never recommend AtomStack to anyone, and I have one.

If it cannot home, how does it know where 0, 0 is?

Do you do the following when you power it up?

I watched one of the videos on the A5, how are you setting 0, 0?

:smiley_cat: