Is there any fix for stopping on All versions past .9.11?

I see that I’m not the only person having problems with the laser stopping. usually it is at the beginning of the job, but sometimes it’s the beginning of a new layer. I’m having same symptoms that have been reported frequently in the past couple months. It shows stream completed but is sitting in the middle of the work piece, usually with the laser still on and burning a hole in the material.

I’ve tried Marlin bugfix version and Marlin 2.0.7. Neither version of Marlin has any problems running a job on 0.9.11. Any of the newer versions just stops and is unusable. I’m feeling pretty disappointed in the fact that the updates lately haven’t corrected the issue. I’m a new user of lightburn and really love the features, but feeling a little bit ripped off that I bought this and it has been unusable since that day, other than an older 0.9.11 version that was emailed to me by another user.

So WHAT has changed as far as how LightBurn interacts with Marlin? How to we get it back to the older way and into a usable machine. I really want to be able to use some of the awesome new features that have been added lately. I feel like it is likely a super simple correction once the issue is found. I’m happy to send my Marlin and Lightburn config files to be examined. This happens with multiple usb cables, multiple usb ports, and even a 2nd computer has the same issue. So I have a hard time blaming it on the computer and cabling. The connection seems to be rock solid until a job is sent. This is definitely a software bug or an incompatible setting.

Please help. I really need to be able to use my machine and don’t want to be stuck on older software or looking for alternatives.

This k40 has a SKR 1.4T board and I can’t seem to find how to properly install GRBL or Smoothie onto it since I have no experience with either and don’t really know what I’m doing. I’m told skr wont work on Smoothie because “the pins are all messed up” which is pretty vague, especially when we can rearrange pins as needed (at least in Marlin). I don’t get it. So did I buy a paperweight of a board? I wanted it to match my large 3D printer so parts are interchangeable and installation on the printer was perfect with this board, even UART drivers and sensorless homing worked well with no headaches. Same on the laser. Everything went smoothly and I only have problems when sending a job from Lightburn.

So Looks like I spend a FORTUNE on a C3D or Gerbil board that only has 2 axis, or I have to find another nice software package that will work with Marlin. I’ve been going in circles with this machine for a month thinking that it was my configs causing problems until I found that the older version of LB works flawlessly and has somehow been broken and appears many others are having the same problem. Is it only on Marlin machines? Please Help

I know the devs have very little time for issues like this, but I’m really hoping someone can help

Josh - first, apologies that I didn’t see this before. For anything that’s a direct request to the developers you’re better off using so it can’t be missed. I try to read everything, but the volume of posts makes that impossible.

Have you tried the current releases?