Is this.... normal?

Hi all,

I’ve got a home-built 90w CO2 laser with a Ruida controller. I’m still experiencing a number of issues, including circles not being round - which looks like major backlash, but I can’t find any backlash in the machine… And this:

That is, in order to get engraving to come out decently, I need a line shift of 4.28mm at 300 mm/s. It took me quite a while to figure out why whenever I try to raster engrave anything it appears to be doubled / ghosted… and it turned out to be the line shift between passes. So after doing a bunch of interval tests I determined that I had over 8mm of line shift when scanning at 300mm… At different speeds the shift is different… Is that normal? It seems like a crazy-high amount to me… If this amount of line-shift is normal, then… ok… But if not, what could be causing it? I’m guessing that it means that the tube takes a significant amount of time to actually fire… Could it be an issue with the Controller, Lase Tube, or Power supply?
Controller is a Ruida RDC6445G
Laser: SPT TR90 (with the red-dot)
Power Supply: Cloudray HY-Z Series Z100 (Cloudray 100-120W AC90-250V HY-Z Series Z100 CO2 Power Supply(With/Wit – Cloudray Laser)


That by itself is not unusual.

However, the value does seem high to me.

If you’re getting backlash in a circle test, you really need to address that before applying any scanning offset adjustment.

What types of motors and drivers are you using?

Are you absolutely certain you’ve removed all mechanical backlash from the system?

Hi thanks for the comment.

I am 99% sure that there is no backlash in the mechanical system… or at least no more than a tiny fraction of a mm.

The motors are closed loop Nema 17s… I tested quite a few different motors before settling on these ones as in my simple bench tests they proved the best.

I can’t find the specs on the encoders in them, but when I tested repeatability it seemed pretty good. I am using 1600 steps per revolution. With my belts that gets me 0.02mm per step. I really hope the motors are not an issue - It’ll be a real pain to change them at this point.

Here is a test of shapes. The top row is at 20mm/s 10% power (air assist off). The second row is 100mm/s at 10% power (air assist off). The problems are always at the intersections where the shape starts/stops.

Here are circles at 10mm/s. The outer circle is 60mm and the inner is 8mm. The outter one looks pretty good (and measures at no more than 0.25mm difference between it’s minimum and maximum diameter. He 8mm inner circle however looks significantly warped.

The same circles, at 100mm/s. Similar results, though the outer circle does have some of a gap.

Any suggestions would be appreciated.


This test file Test.lbrn2 (73.5 KB)
helps to identify backlash amount and which axis is most affected. Run it on some scrap material that will mark (134x104mm).

Are the stepper motors noisy?. Try increasing the micro-stepping resolution at your driver to 3200, see if it makes a difference with the test file. A slightly higher resolution can decrease the chance of resonance issues.

Also check your axis acceleration settings in machine settings aren’t too aggressive.

1 Like

Every time I’ve seen someone use servo motors with a Ruida controller it seems they deal with latency issues. It’s not clear to me what causes this whether it’s a driver issue or possibly a driver configuration issue.

I had previously thought that scanning offset issues were mostly due to latency in laser activation but I’ve seen at least a couple of people on the forum deal with scenarios where the latency is in the motion control.

If what you were dealing with were purely a latency issue I don’t think you’d be dealing with start-end gaps. So you may still have some opportunity to improve on the mechanical side but not certain. Looks like an issue on both X and Y.

Interesting comments… In response to a couple of questions, no the motors are virtually silent in operation… Well with my extractor and fans on I can’t hear them at all… but they’re very quiet in operation. The steps were originally at 3200. The first thing I did when troubleshooting was to reduce to 1600 but it had no effect.

So, running that test file does indeed show some odd issues that I’m not exactly sure how to diagnose… For one, the concentric circles actually look like a spiral on my run. I will post pictures tomorrow.

I tried reducing my acceleration dramatically, but that did not change anything in the slightest… But… thinking about it, It may be possible that latency in my motors is causing this issue… If the laser is firing immediately, but the motor’s ‘intelligent’ controller is taking a few microseconds to process the step pulse and turn it into an actual move command for the PID circuit, then it could result in the laser over-firing in the start position (I do notice a tendency to burn a hole right through at the start, even on low power), and then the laser would turn off before the motor reaches the end of it’s target position so there would be a gap… It never occurred to me that closed loop motors would have this latency, but they could.

I did a little bit of searching and there does seem to be some support for this… It’s a major annoyance to change the motors… but they are fairly accessible I guess… I really like the idea of closed loop motors, but perhaps in this case they’re not an appropriate choice.


I’d love for you to be able to solve for the closed loop servos so that it gets documented with a working solution. Wouldn’t blame you if you punted on it.

I have to think that it’s somehow workable as there are plenty of industrial servo based motors. And there are many CNC machines that use servos. I just have never seen a retrofit in this forum on a Ruida controller where this was done acceptably.

Ditto… I know I’ve read about these on lasers, so it must be possible.

My knowledge of these specialized motor is not that great.


One of my biggest complaints moving from industrial CNC to hobby was the lack of encoders in the drivetrain. Cost. I get it. Still…I can’t count how many hours and dollars I lost because a FDM print failed 3/4 of the way thru a 6, 8,10 hour job because the hotend snagged on something and lost a few steps. Infuriating!

As someone who just acquired a 3D printer with Clearpath servos, I fully understand this sentiment :slight_smile:

With this Test file:
Do you have notes to go with it by chance?
Eg. If Line A is longer than line B, then X stepper calibration needs changing, or backlash is on Y etc etc.


I have plenty of stepper motors around, but no suitable drivers on hand. I’ve ordered some, but it looks like they won’t arrive until Sunday so I won’t be able to test this until next week.

Once I prove that this is the issue I might try servos again and see if there is some way to get it working, but there is very little in the way of configuration options in the Ruida controller for handling this sort of situation so it might just come down to finding some motors that have lower latency, or finding a way to tune the motors themselves.

This is actually the 3rd type of closed loop motor I tried in the machine when I was still working on the mechanics. I also bench-tested 2 or 3 other styles and determined that they were not good enough. For the previous ones I tried I found too much ‘seeking’ and vibrating… In one case I think they could be tuned by connecting to a PC, but I couldn’t get serial cable to work. All of the ones I’ve tried though used the integrated controller ‘backpack’ on the motor. These really just use standard stepper motors with a magnetic encoder on the back part of the shaft. On my CNC machine I use some nema 23 motors that have integrated encoders on the motor and a stand-alone driver… I believe that type is available in Nema 17 so I might give them a go, I suspect they will be of much higher quality, but the two cables required tend to be unwieldy.

I’ll report back here next week. Thanks again everyone for the help.


If you post your results and I’ll add notes to it.

1 Like

Here it is… there is a lot to unpick. The ‘star’ looks quite warped, the concentric circles loo spiral, the ‘sun’ shape is clearly not round… and the middle radial circles are all over the place. I ran this at 200mm/s 10% power in a piece of 3mm MDF without air.

Hopefully when the stepper drivers arrive I can try it again with plain steppers. I ordered what I believe are decent quality drivers, but who really knows when it comes to these things.


i know is not the case, but if this was a diode machine and i was looking at it for diagnostics i would say imediatly
Y belts and X belts are loose :expressionless:
Curiouse about what causes this so will follow along!

Swinging a bit wild here, but do the belts and pinions have the same/complementary profile? If so, is it a low backlash profile?

Even without any potential motion control issues 200mm/s would be quite fast for these kind of line burns. Does dramatically reducing speed affect the outcome?

I suspect you’re running up against minimum power required for lasing to prevent burning but try what you can.

Yes, the belts are all properly tensioned. They are good quality 2GT belts and pulleys, the same type (and supplier) that I have used on a 3d printer and small CNC router in the past.


We’ve seen this before…

Check out this thread… it also has a good thread in one of the responses. I saw a similar one the other day…

Good luck


Indeed, after berainlb mentioned that the closed loop servos could be the problem I did some searching and came to that thread - It sounds to me like I have exactly the same issue.